Bug 58604 - Problem with axmarin when i create keystore
Summary: Problem with axmarin when i create keystore
Alias: None
Product: Android
Classification: Xamarin
Component: Tools and Addins ()
Version: 7.3 (15.2)
Hardware: PC Windows
: --- normal
Target Milestone: master
Assignee: Greg Munn
Depends on:
Reported: 2017-08-06 20:05 UTC by fhsoon2013
Modified: 2017-08-07 03:40 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

keystore (6.62 MB, patch)
2017-08-06 20:16 UTC, fhsoon2013

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description fhsoon2013 2017-08-06 20:05:42 UTC
I have problem when i create keystore in visual studio, i try to resolve in many ways :
download visual studio 2017 , visual studio 2015 and visual studio 2013 
i change my Pc but i have the same problem 
i replace jdk from jdk 1.8.0-92 to  1.8.0-111
but no any one from this fix my problem 
else fill in all the info or not and  if i import have same thing not fix
if any one have my same problem and fix it help me
see the video
Comment 1 fhsoon2013 2017-08-06 20:16:34 UTC
Created attachment 24044 [details]
Comment 2 James Montemagno [MSFT] 2017-08-07 00:21:05 UTC
Read through this documentation:


I watched through the video on twitter and it looked like you didnt' fill out all of the information. I tried to reproduce it and couldn't see: 

It seems like it isn't validating the required fields, but just fill in everything and then it will be created.
Comment 3 James Montemagno [MSFT] 2017-08-07 00:27:10 UTC
I also tested with your exact setting from the video and it worked even without filling out every field. 

I have JDK 1.8.0_112 x64 installed on my machine. 

You should also try to create it manually: https://developer.xamarin.com/guides/android/deployment,_testing,_and_metrics/publishing_an_application/part_2_-_signing_the_android_application_package/visual-studio-xa-4.2.6-to-6.1/

Perhaps tehre is some other issue on your machine.
Comment 4 fhsoon2013 2017-08-07 01:27:58 UTC
I did what you wanted .. Watch video:


i try on my Pc(windows 10) and another Pc(windows 10) is the same problem 
give me details about the version  of visual studio , xamarin , jdk and you system device 

I worked the same as required in the link but did not solve this problem:
Comment 5 James Montemagno [MSFT] 2017-08-07 02:25:46 UTC
Can you try to create the keystore manually via: https://developer.xamarin.com/guides/android/deployment,_testing,_and_metrics/publishing_an_application/part_2_-_signing_the_android_application_package/visual-studio-xa-4.2.6-to-6.1/ and then import it. perhaps something is wrong with the JDK or using some illegal characters.
Comment 6 fhsoon2013 2017-08-07 03:40:48 UTC
when i create keystore in command appear with me this error :