Bug 58180 - Entry did not moves upwards when keyboard is raised
Summary: Entry did not moves upwards when keyboard is raised
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.3.3
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2017-07-16 17:28 UTC by Paul Anderson
Modified: 2018-01-17 10:20 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Sample (70.82 KB, application/zip)
2017-07-16 17:34 UTC, Paul Anderson

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Paul Anderson 2017-07-16 17:28:41 UTC

Comment 1 Paul Anderson 2017-07-16 17:29:17 UTC
In my custom component I have using one property type of Xamarin.Forms View. My scenario is I am adding Xamarin.Forms Entry (or any other text field) to the view and placing the component to bottom of the screen. While focusing the entry keyboard will popup and the field moves above the keypad and allows us to enter value it is the expected behaviour but in may case entry stays at the same position. So we unable to see what we are editing in entry field. Could you please help me on this?.

P.S: Here I have attached the sample for your reference.
Comment 2 Paul Anderson 2017-07-16 17:34:09 UTC
Created attachment 23581 [details]
Comment 3 Jimmy [MSFT] 2017-07-17 16:56:43 UTC
Based on the code it looks like there should be 10 Entry controls on the page, but I ran it on an Android emulator and I am only seeing 6. Additionally, tapping the last Entry does not bring up the keyboard: https://www.dropbox.com/s/u527jhd5flzk81w/2017-07-17_09-45-40.mp4?dl=0

What device/emulator are you testing with? Can you verify that the project you attached is correct? When providing the requested information, please set the report's status back to NEW otherwise we may close this issue after 30 days of no response. Thanks!
Comment 4 Paul DiPietro [MSFT] 2017-08-21 15:21:55 UTC
Per the above comment, we will be closing this issue. Please reopen if the issue is still occurring on the latest prerelease or nightly build with the requested information. Thanks!
Comment 5 Paul Anderson 2017-09-04 10:28:42 UTC
We are using Moto G 4Plus device. In that 10 Entry box will be shown on the screen. When we try to tap on the Entry which has text Click8, the keyboard get enabled. But the Entry box becomes disabled.
Comment 6 Jimmy [MSFT] 2017-09-08 21:33:48 UTC
I am still not sure I understand the issue you are describing. I ran the project on a device with a larger screen and I do now see all the Entry controls. However when I press the last Entry and open the keyboard, the bottom half of the view containing the controls appears to be cut off: https://www.dropbox.com/s/ito0i6a4wzv3csf/b58180.mp4?dl=0

This appears to be related to the custom renderer you are using because if I set the StackLayout that holds the Entry controls to be the direct Content of the Page then it all works as expected. The issue arises when the StackLayout is used in the custom control so this may be an implementation issue rather than a Xamarin.Forms bug.

Can you share a video or screenshot of what you are experiencing?
Comment 7 Paul DiPietro [MSFT] 2017-10-17 15:31:48 UTC
Marking as no response due to one not being given for over 30 days. Please reopen this with the requested information per the above comment if this is still appears to be a non-implementation issue as of the 2.4.0 stable build of Forms.
Comment 8 Paul Anderson 2017-12-07 13:02:21 UTC
Hi Paul Dipietro,

We have took the video of issue reproduced at our end, please check it from the link given below.

Comment 9 Paul DiPietro [MSFT] 2018-01-10 19:12:34 UTC
The link does not work. Please reopen a new issue on GitHub with a minimized reproduction project if this issue still occurs on the latest stable build of Forms.
Comment 10 Paul Anderson 2018-01-17 10:20:41 UTC
I Have created a new GitHub issue with the same issue. 

Issue Link: https://github.com/xamarin/xamarin-android/issues/1199