Bug 58094 - CoreML.MLFeatureDescription.Type could be better named FeatureType or MLFeatureType
Summary: CoreML.MLFeatureDescription.Type could be better named FeatureType or MLFeatu...
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: XI 10.99 (xcode9)
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
: 58092 ()
Depends on:
Reported: 2017-07-12 01:42 UTC by Larry O'Brien
Modified: 2017-07-12 20:03 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Larry O'Brien 2017-07-12 01:42:56 UTC
To avoid confusion, I'd suggest that CoreML.MLFeatureDescription.Type be named `FeatureType` or `MLFeatureType`.
Comment 1 Vincent Dondain [MSFT] 2017-07-12 19:38:11 UTC
Hi Larry,

I'm not sure about this one, the bindings look fine to me.

Just to clarify you're talking about:

[Export ("type")]
MLFeatureType Type { get; }

Member of `MLFeatureDescription`.

So if the proposal is to change type to FeatureType or MLFeatureType I'd argue that the Swift version is also just type: https://developer.apple.com/documentation/coreml/mlfeaturedescription/2879374-type (our naming should be pretty similar to Swift) and that MLFeatureType is an actual enum.

Also can you explain the confusion, I don't get it?

Marking this bug as NEEDINFO to keep the conversation open (:
Comment 2 Larry O'Brien 2017-07-12 19:49:40 UTC
Well, in my opinion, the name `Type` would imply, to a .NET developer, `System.Type`. That's the "confusion" to which I refer, but I also understand the design decision that "No, it's better to use the name that's as close as possible to Apple's."
Comment 3 Vincent Dondain [MSFT] 2017-07-12 20:02:52 UTC
Ok I now understand what you meant.

Indeed we try to stay as close as Apple's APIs, I do not really think there would be a confusion here for C# developers and also we did that in many other places:


^ just to name a few.
Comment 4 Vincent Dondain [MSFT] 2017-07-12 20:03:50 UTC
*** Bug 58092 has been marked as a duplicate of this bug. ***