Bug 58072 - Effects are not being applied to labels
Summary: Effects are not being applied to labels
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.3.4
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jimmy [MSFT]
Depends on:
Reported: 2017-07-11 08:59 UTC by Jim Bennett
Modified: 2017-07-13 00:27 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Jim Bennett 2017-07-11 08:59:47 UTC
I've created an effect and applied it to a Label and an Entry. On iOS this works correctly applying the effect to both controls. On Android the effect is not applied to the label, just the entry.

A reproduction is at https://github.com/jimbobbennett/FormsDroidEffectIssue.

The effect is applied on the PlatformSpecificsPage to a Label and an Entry. On iOS the effect is applied twice, with OnAttached called for the two controls. On Android OnAttached is only called once for the Entry.
Comment 1 Jimmy [MSFT] 2017-07-11 17:05:51 UTC
I ran the GitHub project but I could not reproduce the issue. I ran the app on an Android 7.1 device and both the Label and Entry had the effect applied and I confirmed with debugging that OnAttached() was called for both controls. 

What device or emulator are you experiencing this on? Can you delete the bin/ and obj/ directories and uninstall the app, then redeploy it to see if this continues? Thanks!
Comment 2 Jim Bennett 2017-07-13 00:27:18 UTC
OK - weird. I tried cleaning and rebuilding, including deleting from the emulator and it wasn't working. I've restarted everything including updating to the latest released beta of VS and now it's working.

I'll close the issue.
Comment 3 Jim Bennett 2017-07-13 00:27:28 UTC
Thanks for your help.