Bug 57900 - Fatal error: 'QuartzCore/CAEmitterBehavior.h' file not found
Summary: Fatal error: 'QuartzCore/CAEmitterBehavior.h' file not found
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 10.99 (xcode9)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
: 59089 ()
Depends on:
Reported: 2017-07-02 01:14 UTC by Sarah
Modified: 2017-12-05 00:07 UTC (History)
9 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Sarah 2017-07-02 01:14:52 UTC
Build started 7/1/2017 8:43:51 PM.

Target _ComputeTargetArchitectures:
    ParseDeviceSpecificBuildInformation Task
      Architectures: ARMv7, ARM64
      IntermediateOutputPath: obj/iPhone/Debug/
      OutputPath: bin/iPhone/Debug/
      TargetFrameworkIdentifier: Xamarin.iOS


    Mono Ahead of Time compiler - compiling assembly /Path/to/obj/iPhone/Debug/device-builds/ipad6.7-11.0/mtouch-cache/Build/Mono.Security.dll
    AOTID 2E6099B2-5054-75FF-0EB6-63D035F37979
    Code: 4668(56%) Info: 70(0%) Ex Info: 2416(29%) Unwind Info: 258(3%) Class Info: 28(0%) PLT: 25(0%) GOT Info: 629(7%) Offsets: 188(2%) GOT: 584
    Compiled: 15/15 (100%), No GOT slots: 5 (33%), Direct calls: 1 (11%)
    Output file: '/Path/to/obj/iPhone/Debug/device-builds/ipad6.7-11.0/mtouch-cache/arm64/Mono.Security.dll.s'.
    Linking symbol: '_mono_aot_module_Mono_Security_info'.
    JIT time: 5 ms, Generation time: 6 ms, Assembly+Link time: 0 ms.
    Process exited with code 1, command:
    /Applications/Xcode-beta.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang  -Xlinker -rpath -Xlinker @executable_path -Wno-receiver-forward-class -gdwarf-2 -I/Library/Frameworks/Xamarin.iOS.framework/Versions/ -isysroot /Applications/Xcode-beta.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS11.0.sdk -Qunused-arguments -miphoneos-version-min=10.3 -arch arm64 -c -o /Path/To/obj/iPhone/Debug/device-builds/ipad6.7-11.0/mtouch-cache/arm64/registrar.o -x objective-c++ -DDEBUG /Path/To/obj/iPhone/Debug/device-builds/ipad6.7-11.0/mtouch-cache/registrar.m
    In file included from /Path/To/obj/iPhone/Debug/device-builds/ipad6.7-11.0/mtouch-cache/registrar.m:3:
    /Path/To/obj/iPhone/Debug/device-builds/ipad6.7-11.0/mtouch-cache/registrar.h:12:9: fatal error: 'QuartzCore/CAEmitterBehavior.h' file not found
    #import <QuartzCore/CAEmitterBehavior.h>
    1 error generated.
    MTOUCH : error MT4109: Failed to compile the generated registrar code. Please file a bug report at http://bugzilla.xamarin.com
Done building target "_CompileToNative" in project "ACES.csproj" -- FAILED.

Done building project "ACES.csproj" -- FAILED.


MTOUCH : error MT4109: Failed to compile the generated registrar code. Please file a bug report at http://bugzilla.xamarin.com
    0 Warning(s)
    1 Error(s)

Time Elapsed 00:00:11.70

---------------------- Done ----------------------

Build: 1 error, 0 warnings
Comment 1 Sarah 2017-07-02 01:16:05 UTC
OS version: macOS High Sierra 10.13 Beta (17A291m)
XCode Beta: Version 9.0 beta 2 (9M137d)
Comment 2 Sarah 2017-07-02 01:45:42 UTC
Sorry, I'm new to Visual Studio / Xamarin. I also just noticed this tidbit:
/Path/To/obj/iPhone/Debug/device-builds/ipad6.7-11.0/mtouch-cache/registrar.h(11,11): Warning GD811092D: duplicate protocol definition of 'CALayerDelegate' is ignored (GD811092D)
Comment 3 Rolf Bjarne Kvinge [MSFT] 2017-07-03 05:27:53 UTC
You're using the Xcode 9 beta with the stable version of Xamarin.iOS, but the stable version of Xamarin.iOS does not support the Xcode 9 beta.

We're working on a preview release with Xcode 9 support, but in the meantime you can get daily builds of Xcode 9 compatible Xamarin.iOS here:


More info is available here: https://lists.dot.net/pipermail/macios-devel/2017-June/000046.html
Comment 4 Sarah 2017-07-10 04:40:19 UTC
I meant to add this earlier, but thank you for responding so quickly!
Comment 5 Rolf Bjarne Kvinge [MSFT] 2017-08-29 13:04:02 UTC
*** Bug 59089 has been marked as a duplicate of this bug. ***
Comment 6 Tuyen Duc Vu 2017-10-12 22:54:24 UTC
I faced the same issue while setting up build on Mobile Center
Comment 7 Hrafn Loftsson 2017-10-14 18:29:18 UTC
Same problem here when building an iOS app in Mobile Center.  Is it possible that the Mac agent in Mobile Center does not have newest Xamarin.iOS ( installed?
Comment 8 Julie Misson 2017-10-15 00:35:56 UTC
I also have this problem
Comment 9 Sean Freiburg 2017-11-27 22:00:12 UTC
Me too using VSTS MacOS hosted build.
Comment 10 Chris Sidi [MSFT] (VSTS) 2017-12-01 15:40:02 UTC

For VSTS see https://developercommunity.visualstudio.com/content/problem/152352/vsts-hosted-mac-agent-fails-with.html for a workaround.

If anyone is still seeing this with App Center (previously known as Mobile Center), updating your App Center build so it has a Xamarin SDK version specified and saving may fix the issue. If that doesn't help, intercom chat may be the best support option.

Chris (VSTS)
Comment 11 Sean Freiburg 2017-12-05 00:07:21 UTC
That worked Chris, thanks for the help!
Comment 12 Sean Freiburg 2017-12-05 00:07:35 UTC
That worked Chris, thanks for the help!