Bug 57752 - Android.content.res.Resources$NotFoundException is thrown when WearableActionDrawer is added
Summary: Android.content.res.Resources$NotFoundException is thrown when WearableAction...
Alias: None
Product: Android
Classification: Xamarin
Component: Designer ()
Version: 7.3 (15.2)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jérémie Laval
Depends on:
Reported: 2017-06-26 06:33 UTC by Vladimir Djordjevic
Modified: 2017-07-07 17:33 UTC (History)
2 users (show)

Is this bug a regression?: Yes
Last known good build:

image shows thrown error (12.01 KB, image/png)
2017-06-26 06:33 UTC, Vladimir Djordjevic
requested layout file (817 bytes, application/xml)
2017-07-07 17:21 UTC, Vladimir Djordjevic
error when using your layout (33.17 KB, image/png)
2017-07-07 17:28 UTC, Vladimir Djordjevic

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 57752 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Vladimir Djordjevic 2017-06-26 06:33:51 UTC
Created attachment 23104 [details]
image shows thrown error

After update to latest stable version of Xamarin my projects stopped working and new projects cannot be created because of this error.

Steps to reproduce:
1. Create new android wear project
2. Update all Nuget packages
3. Create new Android Layout
4. Add WearableDrawerLayout
5. Add WearableActionDrawer to WearableDrawerLayout

Android Layout cannot be rendered and error is shown:
android.content.res.Resources$NotFoundException was thrown
Resource ID #0x7f0b002 type #0x0 is not valid
Comment 1 Vladimir Djordjevic 2017-07-03 19:21:55 UTC

any news about this issue?
I need to update one of my live apps and because of this I am blocked.
Comment 2 Jon Douglas [MSFT] 2017-07-07 15:44:33 UTC
Hi Vladimir,

Based on your steps to reproduce, can you please include either A) The layout file that includes WearableDrawerLayout / WearableActionDrawer or B) The relevant code of the layout that is failing to render?

For example, will a layout like the following show the rendered error?


Thus I am marking this bug as NEEDINFO until we can get a layout that you are attempting to run on.

As a side note, please include your Version Information from the IDE you are using.
Comment 3 Vladimir Djordjevic 2017-07-07 17:21:21 UTC
Created attachment 23406 [details]
requested layout file
Comment 4 Vladimir Djordjevic 2017-07-07 17:27:47 UTC
Hi Jon,

new layout file is attached so you can check it.
When I try your layout file different error is shown and you can see it in new image that is also attached.

Here is the versions info:
android wear nuget
vs community 2015 14.0.25431.01 update 3
xamarin (fec6f88)
xamarin android (9dbc4c5)

Note that I've also tried on VS2017 and same error was shown.
Also, this all worked well just before latest Xamarin update. 

Please let me know if you need more info.

Comment 5 Vladimir Djordjevic 2017-07-07 17:28:17 UTC
Created attachment 23407 [details]
error when using your layout
Comment 6 Jon Douglas [MSFT] 2017-07-07 17:33:30 UTC
Thanks for that Vladimir,

I am going to CONFIRM this issue as it seems we are running into either an unsupported scenario, or error within tooling. We will have to wait until our designer engineers take a further look.