Bug 5762 - "Unexpected error" when trying to deploy to iPad that's being profiled in Instruments
Summary: "Unexpected error" when trying to deploy to iPad that's being profiled in Ins...
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: 5.2
Hardware: All Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2012-06-19 17:16 UTC by jesse.attas
Modified: 2013-12-05 18:34 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description jesse.attas 2012-06-19 17:16:56 UTC
While deploying to the iPad, I received an error whose message asked me to file a bug report. Here it is!

Deployment usually works for me (and starting working again after rebooting the iPad and MonoDevelop). One likely cause of the failure is that the iPad was being profiled in Instruments (Time Profiler profiling All Processes) when I tried to deploy it.

Deploy to Device Log:

/Developer/MonoTouch/usr/bin/mtouch -sdkroot "/Applications/Xcode.app/Contents/Developer" -installdev "/Users/jattas/Developer/tfs/R2-Tablets-Dev/Binaries/MonoTouch/Release/DataDashboard.app"
Please ensure your device is connected...
Connected to: jattas’s iPad
error MT0000: Unexpected error - Please fill a bug report at http://bugzilla.xamarin.com
System.Exception: AMDeviceStartSession returned: 0xe800005c
at MonoTouch.Installation.Device.StartSession () <0x0008f>
at MonoTouch.Installation.Installer/<ExecuteWithSession>c__AnonStorey3.<>m__2 (object,System.EventArgs) <0x000db>
at MonoTouch.Installation.Device.NotificationCallback (MonoTouch.Installation.Device/am_device_notification_callback_info&) <0x0006e>
at (wrapper native-to-managed) MonoTouch.Installation.Device.NotificationCallback (MonoTouch.Installation.Device/am_device_notification_callback_info&) <0x0003f>
at (wrapper managed-to-native) MonoTouch.CoreFoundation.CFRunLoop.CFRunLoopRun () <0x00003>
at MonoTouch.CoreFoundation.CFRunLoop.Run () <0x0000b>
at MonoTouch.Installation.Installer.ExecuteWithSession (MonoTouch.Installation.Installer/Executor) <0x000cf>
at MonoTouch.Installation.Installer.InstallApplication (string) <0x0006f>
at MTouch.Main2 (string[]) <0x03b53>
at MTouch.Main (string[]) <0x0001f>

The application was terminated by a signal: SIGHUP

Version Info:

Installation UUID: 1480f558-ce01-4cc9-8f58-058dda76f061
	Mono 2.10.9 (tarball)
	GTK 2.24.10
	GTK# (
	Package version: 210090011
Apple Developer Tools:
	 Xcode 4.3.3 (1178)
	 Build 4E3002
Monotouch: 5.2.12
Mono for Android not installed
Build information:
	Release ID: 30003002
	Git revision: 7bf6ac0ca43c1b12703176ad9933c3484c05c84c-dirty
	Build date: 2012-06-16 04:36:10+0000
	Xamarin addins: 62ad7268d38c2ece7e00dc32960bd3bdab8fec38
Operating System:
	Mac OS X 10.7.4
Comment 1 Sebastien Pouliot 2012-06-21 08:19:21 UTC
Instruments, at least some version of it, keeps a permanent connection with the device (as long as it stays open). This can block some operations. Normally closing Instruments will allow you to resume "normal" deployment of your application (if this issue is identical, let us know if it is not).

Keeping the bug open so we can see if it's possible to detect this and show a better error message.
Comment 2 Sebastien Pouliot 2012-06-21 09:21:53 UTC
> the iPad was being profiled in Instruments (Time Profiler profiling All Processes) 
> when I tried to deploy it

I could not duplicate this during an instrument session (time profiler, all processs). The application rebuilt and deployed correctly, so this could be a different issue (or hard to reproduce). I this repeats itself please add more information to the bug report (we might get lucky and find how to reproduce this).

Repeating my old steps "Instrument record for app A, then stop" I get (with the old install code) the following message (if I tried to deploy app 'A' without closing Instruments).

Please ensure your device is connected...
The device 'Triton' has not been paired to this computer

Note that using the new (5.3.4) fast install code works without an error (the pairing condition is detected and fixed).
Comment 3 PJ 2013-11-19 17:04:32 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 4 PJ 2013-12-05 18:34:37 UTC
This bug has not been changed from the NEEDINFO state since my previous comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing the issue. Please add the requested information and set the bug back to the NEW (or CONFIRMED) state.