Bug 57553 - Unable to build the SceneKitGame Application in VS 2015 when created the Game app in VSfM
Summary: Unable to build the SceneKitGame Application in VS 2015 when created the Game...
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.6.0 (15.3)
Hardware: PC Windows
: Normal normal
Target Milestone: 15.4
Assignee: Joaquin Jares
Depends on:
Reported: 2017-06-16 12:24 UTC by Gaurav Ganorkar
Modified: 2017-08-18 15:51 UTC (History)
13 users (show)

Tags: Globallogic
Is this bug a regression?: Yes
Last known good build: ac

Attached logs and Project (808.15 KB, application/x-zip-compressed)
2017-06-16 12:24 UTC, Gaurav Ganorkar
Attached IDE logs (3.58 KB, application/x-zip-compressed)
2017-07-20 11:23 UTC, Saurabh Paunikar

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Gaurav Ganorkar 2017-06-16 12:24:37 UTC
Created attachment 22943 [details]
Attached logs and Project

-Unable to build the SceneKit Game application which is created in VSfM and Then loaded on the windows VS 2015

Build info
-Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01586

Installed Version: Enterprise

Xamarin (d5e0c2f)
Xamarin.Android (5a73b38)
Xamarin.iOS (104e7b4)

Steps to Reproduce
1-Create an Multipplatform>Scenekit game application in Visual Studio for Mac
2-Now import that project in Windows VS 2015 and Build that application

-Getting "The given path's format is not supported."	ScenKitGame.IOS	C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets

-Project should build successfully

Testrail link

SCreencast link

Attached logs and project

-In VSfM application is able to build 
-In logs getting 

Xamarin.Messaging.Ssh.MessagingFileManager|Error|0|An error occurred downloading files for App ScenKitGame.IOS
System.IO.FileNotFoundException: The file '/Users/rogersmsirfp3.0/Library/Caches/Xamarin/mtbs/builds/ScenKitGame.IOS/626b9258adfc8621a0ae4e8d4a1c7004/obj/iPhone/Debug/build-signature/signature' was not found on the Mac
File name: '/Users/rogersmsirfp3.0/Library/Caches/Xamarin/mtbs/builds/ScenKitGame.IOS/626b9258adfc8621a0ae4e8d4a1c7004/obj/iPhone/Debug/build-signature/signature'
   at Xamarin.Messaging.Ssh.MessagingFileManager.<DownloadFileAsync>d__11.MoveNext() in C:\d\lanes\4985\d5e0c2fa\source\xamarinvs\src\Messaging\Xamarin.Messaging.Ssh\MessagingFileManager.cs:line 171
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Xamarin.Messaging.Ssh.MessagingFileManager.<DownloadFileAsync>d__13.MoveNext() in C:\d\lanes\4985\d5e0c2fa\source\xamarinvs\src\Messaging\Xamarin.Messaging.Ssh\MessagingFileManager.cs:line 198

I have tried with multiple mac agents getting same error
Comment 1 Joaquin Jares 2017-06-19 13:37:08 UTC
Fixed via PR7687
Comment 5 Saurabh Paunikar 2017-07-20 11:22:34 UTC
Observed that bug is not fixed on

Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Xamarin (4c9180d)
Xamarin.Android (bbf378a)
Xamarin.iOS (38d3a2b)

When build getting error "The given path's format is not supported."

ScreenCast Link : https://www.screencast.com/t/nwjqP8pwNeS

Build Info : https://gist.github.com/saurabh-paunikar/29e935392c347df85dd7c8be8f100b80

Attaching IDE log and reopening the issue
Comment 6 Saurabh Paunikar 2017-07-20 11:23:08 UTC
Created attachment 23689 [details]
Attached IDE logs
Comment 7 Prashant [MSFT] 2017-08-10 06:34:41 UTC
This bug exists on VS 2017 Preview 7 too.

# version information

Microsoft Visual Studio Enterprise 2017 Int Preview (DF)
Version 15.3.0 Preview 7.0 [26730.0.d15rel]
Microsoft .NET Framework
Version 4.7.02046

Installed Version: Enterprise

Xamarin (306f76a)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android SDK (0cd0214)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK (bf350ba)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.
Comment 9 Joaquin Jares 2017-08-15 19:04:26 UTC
Tested in 15.4 and master. This is fixed.
Comment 12 Joaquin Jares 2017-08-16 18:03:11 UTC
Found and additional issue. Fixed via 7969.