Bug 57367 - [Smoke VSMF 15.3]Getting error "Application could not be uploaded to the device." when deploying CrossPlatformDebugging solution in iOS device
Summary: [Smoke VSMF 15.3]Getting error "Application could not be uploaded to the devi...
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 10.12 (d15-3)
Hardware: Macintosh Mac OS
: High normal
Target Milestone: 15.3
Assignee: Bugzilla
Depends on:
Reported: 2017-06-12 12:44 UTC by Saurabh Paunikar
Modified: 2017-06-20 05:59 UTC (History)
10 users (show)

Is this bug a regression?: Yes
Last known good build:

Attached are the IDE logs (60.00 KB, application/zip)
2017-06-12 12:44 UTC, Saurabh Paunikar
Ide logs attached (56.62 KB, application/zip)
2017-06-13 05:42 UTC, Saurabh Paunikar
Contains the log for both the provisioning profile (17.64 KB, application/x-zip-compressed)
2017-06-13 17:09 UTC, Gaurav Ganorkar

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Saurabh Paunikar 2017-06-12 12:44:50 UTC
Created attachment 22830 [details]
Attached are the IDE logs

Getting error "Application could not be uploaded to the device." when deploying CrossPlatformDebugging solution in iOS device.
Note: Working fine on iOS simulator 
Steps to Reproduce
1.Open CrossPlatformDebugging in VSFM
2.Select Certificate
3.Select real device
4.Deploy iOS.Debugging or TVOS.Debugging in debug mode

Actual Result

Getting error "Application could not be uploaded to the device."

Expected Result 

Application should get deployed in real device

Reproducing frequency :- 100%

Test plan link :- https://testrail.xamarin.com/index.php?/plans/view/50289

Test case link :-https://testrail.xamarin.com/index.php?/tests/view/14613131&group_by=tests:assignedto_id&group_order=asc&group_id=-1


Build Info: https://gist.github.com/saurabh-paunikar/42c02407455fd3c3700e4a82c5c403b4

OutPut log: https://gist.github.com/saurabh-paunikar/9709f1144c8faba0d7c3d215fbd4b00f

ScreenCast link: https://www.screencast.com/t/buIZefJwE


Attached Logs for more details.
Comment 1 Manish Sinha 2017-06-12 14:47:24 UTC
Can you add AIpad to the provisioning profile which you are using and try out again?
Comment 2 Saurabh Paunikar 2017-06-13 05:41:48 UTC
HI Manish,

I tried the same by using different device which is added in our GL Provisioning profile and observed the same issue.

ScreenCast link: https://www.screencast.com/t/C8MN8lQTk

Build Output: https://gist.github.com/saurabh-paunikar/08d51a11f947b91210f1e47c76cde802

Note: Also attaching generated logs
Comment 3 Saurabh Paunikar 2017-06-13 05:42:43 UTC
Created attachment 22845 [details]
Ide logs attached
Comment 4 Saurabh Paunikar 2017-06-13 09:59:20 UTC

I am using GlobalLogic Provisioning Profile

Signing Identity: Developer:Jacky Vaswani (69CS4H2ZA4)
Provisioning Profile: GL_Development_Profile
Comment 5 Jeffrey Stedfast 2017-06-13 14:43:50 UTC
You need to uninstall the app on the device first. The provisioning profile you chose does not match the existing bundle id of the app that is already on your device causing a mismatch.

As @manish has also pointed out, you also need to make sure that your AiPad device is added to your provisioning profile.
Comment 6 Gaurav Ganorkar 2017-06-13 17:09:25 UTC
Created attachment 22864 [details]
Contains the log for both the provisioning profile


I have taken care of the things you have mentioned above. 1-Removed App on the Device 2-Device have already been added to the Provisioning profile as We were using the same project samples before with the same provisioning profile and It was working fine earlier.

I am getting the same issue for the build given below for the Deployment of the TVoS application on to TVoS device.

Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01586

Installed Version: Enterprise

Xamarin (60c3d0e)
Xamarin.Android (5a73b38)
Xamarin.iOS (104e7b4)

Screencast link-https://www.screencast.com/t/BdIi4FLpmEf3  (Used GL Devlopment profile)

We also tried with the Different signing identiy and provisioning profile suggested by Manish , We are facing the similar kind of issues

https://www.screencast.com/t/hN03KeaO (Used Xamarin QA as Signing identity and Used tvOS Team Provisioning Profile .com.xamarin.* ) 

Note- TVoS Device UDID is already present in the above Provisioning profile
Comment 7 Emanuel 2017-06-15 21:04:40 UTC
Hi guys, I cannot reproduce this issue with the latest VS for Win bits (v4.6.0.261) and an iPhone 6S running iOS 10.3.2.

This bug is kind of a mess, it was filed against VSFM and in the latest comment it seems there's a repro from VSFW too, but it's not really clear, could someone try this from both IDEs and get a final result?

Comment 8 Adrian Alonso 2017-06-16 11:18:32 UTC
Moved to iOS component for now (it does not seem to be a VS IDE specific issue so far)
Comment 9 Saurabh Paunikar 2017-06-19 12:08:20 UTC
Not able to reproduce this issue on latest builds


Build Info:https://gist.github.com/saurabh-paunikar/c4b498b1c775cb26179cce20868cf6d2


Build Info:https://gist.github.com/saurabh-paunikar/b466e73e29e0e16b6c66c4fab52a6299
Comment 10 Saurabh Paunikar 2017-06-20 05:59:18 UTC
Verified. issue is not reproducing