Bug 57241 - [xtro] Re-enable sharpie on InputMethodKit
Summary: [xtro] Re-enable sharpie on InputMethodKit
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Infrastructure (internal) ()
Version: unspecified
Hardware: PC Mac OS
: --- minor
Target Milestone: Future Cycle (TBD)
Assignee: Alex Soto [MSFT]
Depends on:
Reported: 2017-06-07 14:12 UTC by Alex Soto [MSFT]
Modified: 2017-11-09 14:49 UTC (History)
3 users (show)

Is this bug a regression?: No
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Alex Soto [MSFT] 2017-06-07 14:12:05 UTC
From https://github.com/xamarin/xamarin-macios/pull/2180

InputMethodKit in Xcode 9 Beta 1 ships with a broken module
so we ignore it for now, this allows xtro to work

TODO: Basically revert the above PR once InputMethodKit works
Comment 1 Sebastien Pouliot 2017-06-30 14:05:52 UTC
@Alex please check back with beta 2 if this was solved. Thanks!
Comment 2 Alex Soto [MSFT] 2017-06-30 15:17:34 UTC
I did but the issue is still there, forgot to report back
Comment 3 Alex Soto [MSFT] 2017-07-19 13:42:12 UTC
Still not fixed in Beta 3
Comment 4 Sebastien Pouliot 2017-07-26 20:05:39 UTC
Still broken in beta 4
@Alex did you file a rdar for that one ?
Comment 5 Sebastien Pouliot 2017-08-09 16:09:35 UTC
Issue remains with beta 5.
Comment 6 Sebastien Pouliot 2017-08-25 21:45:04 UTC
broken with beta 6
Comment 7 Alex Soto [MSFT] 2017-09-04 19:04:45 UTC
Oh, missed your ping here.

I did not because I could not make Xcode 9 complain about it and still can't :/
Comment 8 Sebastien Pouliot 2017-09-08 19:43:29 UTC
That issue existing in Xcode 8.3 and it's not clear when (or if) Apple will fix it
Comment 9 Alex Soto [MSFT] 2017-11-09 00:40:03 UTC
This has been fixed in Xcode 9.2 Betas

PR: https://github.com/xamarin/xamarin-macios/pull/2987
Comment 10 Alex Soto [MSFT] 2017-11-09 14:49:40 UTC
merged in xamarin-macios/xcode9.2 @ https://github.com/xamarin/xamarin-macios/commit/f2da9cde6b8e9599387be14ae84526674097fc52