Bug 57032 - [Solved] Unable to start the application in iOS Simulator (exit immediately)
Summary: [Solved] Unable to start the application in iOS Simulator (exit immediately)
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2017-06-01 03:28 UTC by nobita723
Modified: 2017-06-01 04:57 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

ide log (28.64 KB, application/octet-stream)
2017-06-01 03:28 UTC, nobita723

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description nobita723 2017-06-01 03:28:08 UTC
Created attachment 22610 [details]
ide log

I cannot start my application in my iOS Simulator in debug mode after I have performed an update of Visual Studio yesterday. The app started with an launch screen and exit immediately with following message:

Launching 'Myapp.iOS' on 'iPhone 7 Plus iOS 10.3'...
The app has been terminated.
Launch failed. The app 'Myapp.iOS' could not be launched on 'iPhone 7 Plus iOS 10.3'. Error: An error occurred while executing MTouch. Please check the logs for more details.

-----Visual Studio Environment (Windows)-----
Visual Studio Community version: 15.2(26430.12)
xamarin (1be4f0c)
Xamarin.iOS and Xamarin.Mac SDK: (4cffddf)

-----Visual Studio Environment (Mac)-----
Visual Studio for mac Community version: 7.0.1(build 24)
Comment 1 nobita723 2017-06-01 04:57:07 UTC
The problem solved after I removed and added some nuget packages again.