Bug 56982 - Live Player doesn't work over tethered WiFi
Summary: Live Player doesn't work over tethered WiFi
Alias: None
Product: Live Player
Classification: Xamarin
Component: General ()
Version: 1.0.253
Hardware: Macintosh Mac OS
: --- minor
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2017-05-31 00:28 UTC by david
Modified: 2018-01-26 23:40 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Logs from VS Mac IDE (78.34 KB, text/plain)
2017-05-31 00:28 UTC, david
Logs for comment 2 (46.33 KB, text/plain)
2017-05-31 02:05 UTC, david

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 56982 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:

Description david 2017-05-31 00:28:49 UTC
Created attachment 22566 [details]
Logs from VS Mac IDE

Create MvvmCross project on VS Mac using latest templates (v1.4.7).

Project builds OK and runs OK in simulator/emulator on my Mac.

Tether my iPhone to the Mac to create a local WiFi.

Run Xamarin Live Player app on the phone.

Select the iPhone Player in VS Mac target drop-down and hit Play button.

Code fails to download to player with exception: "Error: The type or namespace name 'Core' could not be found (are you missing a using directive or an assembly reference?)". I suspect this is not the real error.

Logs attached.

PS The log timestamps aren't correct. They show time as Z (i.e. they've taken local time and just stuck a Z on the end of it) when I'm in Australia at UTC+10.

PPS: My VS Mac configuration:

=== Visual Studio Community 2017 for Mac (Preview) ===

Version 7.1 Preview (7.1 build 583)
Installation UUID: 50bf73b7-e4df-4e0d-9f0b-063d0469e3b3
	Mono (2017-04/4a0006f) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 502000104

=== NuGet ===


=== .NET Core ===

Runtime: /usr/local/share/dotnet/dotnet
SDK: /usr/local/share/dotnet/sdk/1.0.4/Sdks
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.2.0/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.5.4
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Xamarin.Android ===

Version: (Visual Studio Community)
Android SDK: /Users/davidd/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)
		7.0   (API level 24)
		7.1   (API level 25)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 25.0.4
SDK Build Tools Version: 25.0.1

Java SDK: /usr
java version "1.8.0_102"
Java(TM) SE Runtime Environment (build 1.8.0_102-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.102-b14, mixed mode)

Android Designer EPL code available here:

=== Apple Developer Tools ===

Xcode 8.3.1 (12170)
Build 8E1000a

=== Xamarin Inspector ===

Version: 1.3.0-alpha1
Hash: 0855e01
Branch: master
Build date: Thu, 11 May 2017 04:16:13 GMT

=== Xamarin.Mac ===

Version: (Visual Studio Community)

=== Xamarin.iOS ===

Version: (Visual Studio Community)
Hash: 7571635e
Branch: master
Build date: 2017-05-09 16:04:54-0400

=== Build Information ===

Release ID: 701000583
Git revision: 445a7f09feca58babb966e0c66a6b299d0bd450c
Build date: 2017-05-12 16:05:38-04
Xamarin addins: f9b72ca5f6ca5d9476d8f58353ada2afd56c549b
Build lane: monodevelop-lion-d15-3-preview

=== Operating System ===

Mac OS X 10.12.5
Darwin 16.6.0 Darwin Kernel Version 16.6.0
    Fri Apr 14 16:21:16 PDT 2017
    root:xnu-3789.60.24~6/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

Gist Ide Information 1.1.0
MvvmCross Template pack 1.4.7
AddinMaker 1.3.7
FileNesting 0.1.1
NuGet Package Explorer 0.1
NuGet Package Management Extensions 0.12.2
Paket 0.3
xUnit.NET 2 testing framework support 0.7.5
Comment 1 James Montemagno [MSFT] 2017-05-31 01:35:46 UTC
Have you tried some of the working samples: https://forums.xamarin.com/discussion/95400/samples-from-build-2017-sessions#latest

Just to see if it is an MvvmCross thing or actually related to the WiFi.
Comment 2 david 2017-05-31 02:04:38 UTC
Not sure how it could realistically be anything to do with MvvmCross. The project fails to download to the player, so it's not a runtime problem (i.e. it's before MvvmCross even gets in the picture).

Having tried the "MasterDetail" app I find that doesn't work either.

I have enclosed the logs from this run for info.
Comment 3 david 2017-05-31 02:05:56 UTC
Created attachment 22567 [details]
Logs for comment 2
Comment 4 david 2017-05-31 02:25:26 UTC
Have added requested info so resetting status to New.
Comment 5 James Montemagno [MSFT] 2018-01-26 23:40:25 UTC

I now have this working on Android and working on iOS. Should be available in future update.