Bug 56840 - Build seems to never end in VS2017
Summary: Build seems to never end in VS2017
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 4.5.0 (15.2)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2017-05-25 15:21 UTC by pat
Modified: 2017-06-21 18:57 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Diagnostic Build Output (4.22 MB, application/x-zip-compressed)
2017-05-25 15:46 UTC, pat

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description pat 2017-05-25 15:21:46 UTC
Xamarin 4.5.0443
VS 2017

I am attempting to contribute to a large Open Source solution of 140+ projects (MVVMCross).

I was getting countless errors 

Could not write lines to file "obj\Debug\MvvmCross.Platform.csproj.FileListAbsolute.txt". The process cannot access the file 'C:\Projects\MVVMCross\MvvmCross\Platform\Platform\obj\Debug\MvvmCross.Platform.csproj.FileListAbsolute.txt' because it is being used by another process.

I checked all the Xamarin Build Target files and they all have Continue set on the Target that writes this.

Sometimes it all "just works". Currently I am not getting hundreds of the "could not write lines to file" errors I just get a couple. However the build just seems to hang (VS totally responsive) after 

2>Done building project "NativeToXF.csproj".

NativeToXF is the project I am trying to deploy so I assume it is the last project it needed to build.

If I select "Build -> Cancel" the VS Just-In-Time Debugger dialog pops up offering the opportunity to debug. Doing that gives me nothing.

If i run again with full Diagnostic mode on the build the lines it is hanging on are

2>Task Parameter:Overwrite=False
2>Done executing task "WriteLinesToFile".
2>Done building target "GetBuiltProjectOutputRecursive" in project "MvvmCross.Droid.csproj".
2>Done building project "MvvmCross.Droid.csproj".

I have tried Emulator and actual device.
Comment 1 pat 2017-05-25 15:46:30 UTC
Created attachment 22463 [details]
Diagnostic Build Output

I had to ZIP it as it was too large in its standard format
Comment 2 pat 2017-05-25 16:14:37 UTC
For the record I have the same hanging in VS2015
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2017-05-26 03:57:28 UTC
## Cross-referencing note for the Xamarin team

There is additional background information from the reporter of this bug on Bug 54467, Comment 18 through Bug 54467, Comment 23.

## Quick note to the reporter

Thanks for the new bug report!  New bug reports have higher visibility to the Xamarin team for investigation than comments on bugs that are marked as verified fixed (once those bugs have been idle for a few weeks), so this new bug report is a good step.
Comment 4 Adrian Alonso 2017-06-21 18:57:33 UTC
Hi Pat, we have removed the GetBuiltProjectOutputRecursive target and replaced with a better approach. Please try the latest stable (

Please reopen if you're still able to reproduce the issue.