Bug 56835 - Connecting to Mac Agent, Cant Connect.
Summary: Connecting to Mac Agent, Cant Connect.
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: 15.4
Assignee: mag@xamarin.com
Depends on:
Reported: 2017-05-25 12:57 UTC by Sam Elson
Modified: 2017-07-05 11:17 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Visual studio 2015 alpha logs (12.00 KB, application/octet-stream)
2017-05-25 12:57 UTC, Sam Elson
Verbose Logs (10.69 KB, application/zip)
2017-05-25 14:36 UTC, Sam Elson

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Sam Elson 2017-05-25 12:57:23 UTC
Created attachment 22457 [details]
Visual studio 2015 alpha logs

Hello, I am running Mac Os Sierra parallels,

Unfortunately, I get the error Can't Connect to Sam's iMac, Please try again.

I have tried everything on the connecting to a Mac troubleshooting page https://developer.xamarin.com/guides/ios/getting_started/installation/windows/connecting-to-mac/troubleshooting/

I have also looked through every similar post on this forum and have tried every possible solution, but I am still getting the error. 

I can get an ssh connection via Git bash and execute commands as well completely fine.

I have tried visual studio 2015 on Windows 7 and I have tried visual studio 2017 on Windows 10, I have tried both in alpha and in stable. The mac agent does seem to find the mac as it creates the XMA files every time i delete it, although it has only successfully connected once. I have attached my logs from visual studio 2015, please let me know if you need more information. Thank you.

/* Output Window outputs:
Starting connection to Mac
Installing Broker
Uploading Broker (160/1538 KB) 10%...
Uploading Broker (320/1538 KB) 20%...
Uploading Broker (464/1538 KB) 30%...
Uploading Broker (624/1538 KB) 40%...
Uploading Broker (784/1538 KB) 50%...
Uploading Broker (928/1538 KB) 60%...
Uploading Broker (1088/1538 KB) 70%...
Uploading Broker (1232/1538 KB) 80%...
Uploading Broker (1392/1538 KB) 90%...
Uploaded Broker 100%
Starting Broker in port 52050...
Couldn't connect to Sam’s iMac. Please try again.
Comment 1 Sam Elson 2017-05-25 14:36:31 UTC
Created attachment 22459 [details]
Verbose Logs
Comment 2 Sam Elson 2017-05-25 14:41:16 UTC
Also the logs on the mac say "May 25 15:31:58 sparedev2 com.apple.xpc.launched[1] (come.openssh.sshd.3C4F617A-9923-4BAD-9884-DFE5475838DF[5960]): Service exited with abnormal code: 255"
Comment 3 Adrian Alonso 2017-06-21 19:01:36 UTC
Hi Sam,

It would be great if you could attach the mac logs (˜/Library/Logs/Xamarin-4.5) which are not automatically included in the zip because of the failing connection.

Comment 4 mag@xamarin.com 2017-07-05 02:54:01 UTC
Do you have any extra information or update about this problem?
Comment 5 Sam Elson 2017-07-05 11:16:35 UTC
Hi there,

Sorry for the late reply, I have solved the issue now. I fixed it by downgrading to El Capitan OS. 

Thank you anyway.
Comment 6 Sam Elson 2017-07-05 11:17:24 UTC