Bug 56760 - Add > Class in WatchOS extension opens dialog to add Xamarin Forms
Summary: Add > Class in WatchOS extension opens dialog to add Xamarin Forms
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.5.0 (15.2)
Hardware: PC Windows
: Normal normal
Target Milestone: 15.4
Assignee: Bugzilla
Depends on:
Reported: 2017-05-23 13:58 UTC by Ivan Icin
Modified: 2017-06-23 15:01 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Ivan Icin 2017-05-23 13:58:25 UTC
When clicking Add > Class it is expected that I get the dialog with selected option to add a new Class. However in WatchOS extension project it opens a dialog to add Xamarin Form.
Comment 1 Emanuel 2017-05-26 17:06:46 UTC
Hi Ivan, I've tried to reproduce this issue with no luck, so I'll need some info from your side:

- Could you attach your environment information (You can find it on Help - >About Microsoft Visual Studio)? 
- What type of projects are you using? Are you developing a Xamarin Forms app with a watchOS app? Or are you developing a regular iOS app with a watchOS app?

Thanks for reporting!
Comment 2 Ivan Icin 2017-05-30 19:59:23 UTC
I can still reproduce it. It is Xamarin.iOS project not Xamarin.Forms. I haven't tried with an empty project but on this project it is always as described above.

Here is the env info:

Microsoft Visual Studio Community 2017 
Version 15.2 (26430.6) Release
Microsoft .NET Framework
Version 4.7.02046

Installed Version: Community

Visual Basic 2017   00369-60000-00001-AA505
Microsoft Visual Basic 2017

Visual C# 2017   00369-60000-00001-AA505
Microsoft Visual C# 2017

Visual C++ 2017   00369-60000-00001-AA505
Microsoft Visual C++ 2017

Visual F# 4.1   00369-60000-00001-AA505
Microsoft Visual F# 4.1

Application Insights Tools for Visual Studio Package   8.6.00404.2
Application Insights Tools for Visual Studio

ASP.NET and Web Tools 2017   15.0.30503.0
ASP.NET and Web Tools 2017

Common Azure Tools   1.9
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

JavaScript Language Service   2.0
JavaScript Language Service

JavaScript Project System   2.0
JavaScript Project System

JavaScript UWP Project System   2.0
JavaScript UWP Project System

Merq   1.1.17-rc (cba4571)
Command Bus, Event Stream and Async Manager for Visual Studio extensions.

Microsoft Visual Studio VC Package   1.0
Microsoft Visual Studio VC Package

Mono Debugging for Visual Studio   Mono.Debugging.VisualStudio
Support for debugging Mono processes with Visual Studio.

Multilingual App Toolkit   4.0
Multilingual App Toolkit helps you localize your Windows Store app by providing file management, pseudo and machine translation, translation editor, and build integration. http://aka.ms/matinstall

NuGet Package Manager   4.2.0
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

TypeScript tools for Visual Studio

Visual Studio Tools for Universal Windows Apps   15.0.26430.06
The Visual Studio Tools for Universal Windows apps allow you to build a single universal app experience that can reach every device running Windows 10: phone, tablet, PC, and more. It includes the Microsoft Windows 10 Software Development Kit.

Xamarin (c871575)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android SDK (448f54f)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK (30b6e87)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.
Comment 3 Jose Gallardo 2017-06-21 18:39:21 UTC
Hi Ivan,

We've been trying to reproduce this issue without success.
Can you please attach/link a screencast for us? We think that might help us to find out something we're missing.

Comment 4 Ivan Icin 2017-06-23 14:39:29 UTC
After updating to the latest Visual Studio few days ago I can't reproduce the issue anymore.

I am not sure should I mark it with "not reproducible" "fixed" or whatever (different projects have different strategies regarding this I think), so please close the bug for me.
Comment 5 Emanuel 2017-06-23 15:01:27 UTC
Closing this bug as Not Reproducible.

Thanks Ivan!