Bug 56596 - not able to connect mac after upgrading xamarin to 4.5
Summary: not able to connect mac after upgrading xamarin to 4.5
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: XMA ()
Version: 4.5.0 (15.2)
Hardware: PC Windows
: Normal normal
Target Milestone: 15.4
Assignee: mag@xamarin.com
Depends on:
Reported: 2017-05-18 07:34 UTC by Aravind
Modified: 2017-07-31 18:36 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Log Zip (3.73 KB, application/x-zip-compressed)
2017-05-18 07:34 UTC, Aravind
Screen Shot of mac agent (30.45 KB, image/png)
2017-05-18 07:38 UTC, Aravind
Attached IDE logs (3.86 KB, application/x-zip-compressed)
2017-07-27 09:55 UTC, Saurabh Paunikar

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Aravind 2017-05-18 07:34:57 UTC
Created attachment 22251 [details]
Log Zip

  I have upgraded xamarin in windows 10 pc from 4.2 to 4.5 from VS2015. I was not able to connect the mac, Mac agent trying to connect the mac but it is not moving from this point. If I downgrade again and tries to connect the same, I was able to connect successfully.

when I looked into the log there was this error after broker is  initialized successfully.

Xamarin.Messaging.Client.MessagingClient|Verbose|0|Sending Request Xamarin.Messaging.GetActiveClientsMessage to topic xma/clients|2017-05-18 06:22:34Z
Xamarin.Messaging.Client.ApplicationMessageExtensions|Warning|0|Error converting value System.Byte[] to type 'System.Guid'.
Newtonsoft.Json.JsonSerializationException: Error converting value System.Byte[] to type 'System.Guid'. ---> System.Exception: Could not cast or convert from System.Byte[] to System.Guid.
   at Newtonsoft.Json.Utilities.ConvertUtils.EnsureTypeAssignable(Object value, Type initialType, Type targetType)
   at Newtonsoft.Json.Utilities.ConvertUtils.ConvertOrCast(Object initialValue, CultureInfo culture, Type targetType)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.EnsureType(Object value, Type targetType)

Please let me know anything needed. I have attached logs.

Comment 1 Aravind 2017-05-18 07:38:08 UTC
Created attachment 22253 [details]
Screen Shot of mac agent
Comment 2 vga 2017-05-18 13:22:31 UTC
Hi Aravind,

Thanks for reporting this. Could you please let us know which build of Xamarin.iOS are you running in the Mac?

Comment 3 Aravind 2017-05-18 13:23:48 UTC
Comment 4 Aravind 2017-05-19 07:05:49 UTC
Windows Configuration

System Info:
Xamarin (c871575)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android (448f54f)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS (30b6e87)
Visual Studio extension to enable development for Xamarin.iOS.


Xamarin Studio Community
Version 6.3 (build 864)
Installation UUID: dfbf346f-829a-4a9c-9284-2bbb8d483d11
	Mono (2017-02/9667aa6) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 500000100


'/Applications/Xamarin Profiler.app' not found

Not Installed

Apple Developer Tools
Xcode 8.3.1 (12170)
Build 8E1000a

Xamarin.Mac not installed. Can't find /Library/Frameworks/Xamarin.Mac.framework/Versions/Current/Version.

Version: (Xamarin Studio Community)
Hash: 3e5ac5ff
Branch: d15-2
Build date: 2017-05-05 18:11:38-0400

Xamarin Inspector
Not Installed

Build Information
Release ID: 603000864
Git revision: 6c2f6737278ccc3e81e12276d49c0d92f975f189
Build date: 2017-04-24 11:26:01-04
Xamarin addins: d8d46e577d8507c35260ce9d73df3c33415bb214
Build lane: monodevelop-lion-d15-1

Operating System
Mac OS X 10.12.0
Darwin Maithri-iMac.local 16.0.0 Darwin Kernel Version 16.0.0
    Mon Aug 29 17:56:20 PDT 2016
    root:xnu-3789.1.32~3/RELEASE_X86_64 x86_64
Comment 5 Aravind 2017-05-23 11:37:58 UTC
System Info shared
Comment 6 mag@xamarin.com 2017-06-23 21:43:57 UTC

I was trying to reproduce the issue, but I couldn't get any connection error.
I can see in the screenshot that you have many Macs in the network. Are you getting the same error and behaviour for every Mac? On the other hand, can you still reproduce the issue consistently with the latest Xamarin version?

Finally, given that the Broker is starting, It would be helpful to see if there is any error on that side, so can you please share the Broker.log and Broker.stderr.log? You can get them from here in the Mac: ~/Library/Logs/Xamarin-x.x/
Comment 7 mag@xamarin.com 2017-07-05 02:55:42 UTC
Do you have any extra information or update about this problem?
Comment 8 Aravind 2017-07-05 04:17:40 UTC
  After uninstalling ncover extension for visual studio 2015, it got worked but i still wonder why mac agent failed to connect mac when ncover was installed

Comment 12 Jose Gallardo 2017-07-31 18:36:09 UTC
Hi @Aravind,

All the extensions installed on Visual Studio and running at the same time share the same loaded assemblies, which means that if a given extension (like in this case NCover) is loading a different version (mostly an older version) of a common dependency (i.e. NewtonSoft.Json), then our extension will fail eventually, because that loaded version of the assembly may have a different method signature or class definition than what we expect.

Not sure what's the exact different dependency version in this case, but such incompatibilities between VS extensions is not new, and we've found similar cases before.

In some other cases installing the latest version of the incompatible extension helped resolving it, as in general we're always using the latest version for every dependency. But we cannot promise that will work for this case.

Marking the bug as RESOLVED - ANSWERED.

Thanks and hope this helps you to understand the issue.