Bug 56336 - Unable to start Google Emulator Manager
Summary: Unable to start Google Emulator Manager
Status: RESOLVED DUPLICATE of bug 56203
Alias: None
Product: Android
Classification: Xamarin
Component: SDK Manager ()
Version: 7.3 (15.2)
Hardware: PC Mac OS
: --- normal
Target Milestone: 15.3
Assignee: Lluis Sanchez
Depends on:
Reported: 2017-05-13 09:49 UTC by Curia Damiano
Modified: 2017-06-27 14:31 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Curia Damiano 2017-05-13 09:49:17 UTC
I've installed VS4Mac (first: with Xamarin Studio; then: reformatting completely the Mac and installing only VS4Mac).
While the SDK Manager works, I'm absolutely not able to start the Google Emulator Manager.
When I select this menu item, nothing happens (no errors, no windows shown).
So I can't configure my Android emulators.
Regards, Damiano
Comment 1 Sevket Kizanlik 2017-05-15 20:03:36 UTC

"Manage Google Emulators..." item in the device / emulator picker doesn't work. It acts as a device or emulator. It is "selectable". When it is clicked, a tick sign appears on left.

If I run the app while "Manage Google Emulators..." is selected, the first device (physical or emulator) is picked and the app is installed and run on it.

Please consider this situation while fixing this bug.
Comment 2 Nina 2017-05-16 14:48:10 UTC
This is because the standalone manager has been deprecated by Google. Xamarin is working on a replacement, but it will be a little while until it is ready.

Some workarounds are available here: https://forums.xamarin.com/discussion/92430/standalone-sdk-manager-and-avd-manager-are-deprecated-since-android-studio-2-3

We should also disable that menu option in the IDE if the manager is not detected (cc: lluis).
Comment 3 Curia Damiano 2017-05-17 08:38:07 UTC
what is strange is that this still works fine in my PC (VS2017.2)
What command should I run on my Mac?
Comment 4 Vsevolod Kukol 2017-06-27 14:31:34 UTC
We have still no replacement for the AV Manager, but we show a warning since, hence marking this as resolved/duplicate

*** This bug has been marked as a duplicate of bug 56203 ***