Bug 56235 - App icon isn't showing iOS
Summary: App icon isn't showing iOS
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 10.10 (d15-2)
Hardware: PC Mac OS
: Normal normal
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
Depends on:
Reported: 2017-05-11 17:35 UTC by Mathieu Morrissette
Modified: 2017-06-16 21:35 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

project to reproduce the issue (645.30 KB, application/zip)
2017-05-11 17:35 UTC, Mathieu Morrissette

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Mathieu Morrissette 2017-05-11 17:35:10 UTC
Created attachment 22095 [details]
project to reproduce the issue


I recently updated to the latest stable version of visual studio for mac but I have an issue.
The icon for my iOS app isn't showing anymore on the home screen it just shows the default one from apple.
I've looked into the app bundle produced after building it and I couldn't find the app icon inside it.

I made a simple xamarin.ios project for you guys to reproduce.
Comment 1 Timothy Risi 2017-05-11 22:10:36 UTC
Hi,  I downloaded your repro and can confirm I'm seeing the same thing.  While we look into what caused it in the first place, there's an easy workaround.  I went into the AppIcon asset catalog and clicked on the icons to pick images and just set them back to the ones they were already supposed to be using and the icon showed up successfully when I ran it.
Comment 2 Vincent Dondain [MSFT] 2017-05-12 00:11:04 UTC

So the ACTool task is giving us a bunch of warnings: https://gist.github.com/VincentDondain/09e7ad90a9647630948678b030c60bdb

It can't find the icon files.

What happens it that those files are not included in the project (for some reason), they are not referenced in the csproj.

An other workaround here would be to right click on the solution in the solution pad > Display Options > Show All Files.

Dive into the xcassets folder and appiconset, select all greyed out icons, right click and select "Include in Project".


Now I'm confused as to how you got into this scenario.

Could you please detail the specific steps to reproduce this issue when creating a new project (like the one you created as a test case) because if I add the icons via the asset editor they are successfully included in the csproj (the workaround Tim suggested).

Also please give us your full version informations.

The easiest way to get exact version information is to use the "Xamarin Studio" menu, "About Xamarin Studio" item, "Show Details" button and copy/paste the version informations (you can use the "Copy Information" button).
Comment 3 Mathieu Morrissette 2017-05-12 15:46:08 UTC
I used a tool to generate the icons. I never used the UI provided by Xamarin/VS For Mac to add icons. It was working before the update even without including the files inside the csproj. I was able to fix my issue by including the files.
Comment 4 Vincent Dondain [MSFT] 2017-05-12 22:15:32 UTC

Any chance you can give us the version of VSMac/Xamarin Studio where it did work? I'm having trouble reproducing this even with older versions (tried with XS 6.1).

As far as I can tell the MSBuild ACTool task (which is the one responsible for processing assets) always required images to have the "ImageAsset" build action, therefore being included in the csproj.

I also checked if we somehow could have automatically added assets within the xcasset folder to the project (which would have added the "ImageAsset" build action by default) but that doesn't seem to be the case.

Could you have been **importing** assets with our asset editor in the past? Because that would be the correct way to do it even if you are not using our UI to add the images individually.

This would be: double click on Assets.xcasset, right click in the left hand side pad and select "Import".


I believe there have been discussions about not needing special build actions for xcassets in the past and people suggested: "that we have a prior target that builds up the @(ImageAsset) from the Contents.json" but I don't think it has been implemented. We'd need @jeff's input on that.
Comment 5 Vincent Dondain [MSFT] 2017-06-16 21:35:43 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!