Bug 56201 - Publishing archives doesn't upload msym files created with <MonoSymbolArchive> set in csproj
Summary: Publishing archives doesn't upload msym files created with <MonoSymbolArchive...
Alias: None
Product: Android
Classification: Xamarin
Component: Linker ()
Version: 7.3 (15.2)
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Radek Doulik
Depends on:
Reported: 2017-05-10 20:37 UTC by Jeremy Kolb
Modified: 2017-06-28 18:07 UTC (History)
2 users (show)

Tags: 15.2I bb ac
Is this bug a regression?: ---
Last known good build:

System info (3.18 KB, text/plain)
2017-06-28 18:07 UTC, Mark McLemore

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 56201 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Jeremy Kolb 2017-05-10 20:37:24 UTC
# Steps to reproduce
Add <MonoSymbolArchive>True</MonoSymbolArchive> to your csproj
Build and Archive, publish to google play.

# Expected behavior
Msym files are uploaded.

# Actual behavior
They aren't.
Comment 1 Mark McLemore 2017-06-28 18:07:38 UTC
Confirmed using the following steps:

1. Create a Xamarin.Android project from the blank template.
2. Change solution configuration to Release.
3. Add <MonoSymbolArchive>True</MonoSymbolArchive> to the Release section of the .csproj file
4. Build and archive.
5. Publish Ad-hoc to an APK.
6. Unzip the APK -> no msym files were included.

Also tried this with <AndroidManagedSymbols>True</AndroidManagedSymbols> (in case there is a regression from 44447): same result, no msym files.
Comment 2 Mark McLemore 2017-06-28 18:07:57 UTC
Created attachment 23180 [details]
System info