Bug 56035 - Connection from Visual Studio to iOS build host unstable
Summary: Connection from Visual Studio to iOS build host unstable
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.4.0 (15.1)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2017-05-05 14:07 UTC by Michael Rumpler
Modified: 2017-10-12 07:22 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Logs of past week (69.22 KB, application/x-zip-compressed)
2017-05-05 14:07 UTC, Michael Rumpler
Xamarin VS versions (3.21 KB, text/plain)
2017-05-05 14:08 UTC, Michael Rumpler
Xamarin versions on Mac (1.80 KB, text/plain)
2017-05-05 14:08 UTC, Michael Rumpler
Diagnostic build which failed (1.17 MB, application/x-zip-compressed)
2017-05-05 14:12 UTC, Michael Rumpler

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Michael Rumpler 2017-05-05 14:07:37 UTC
Created attachment 21976 [details]
Logs of past week

In the last week or so most of the time when I try to build and deploy to my iOS device I get errors. The build always fails with a different error message related to the connection to the Mac.

In the Output/Xamarin window I get these messages repeated every few minutes:

Disconnected from the Mac McMinnie.local. (
The underlying client has been disconnected by the remote host
Starting reconnection...
Starting connection to Mac
Downloading /Users/Michael/Library/Logs/Xamarin-4.4/2017-05-03__16-53-36.19496.Broker.log...
Downloading /Users/Michael/Library/Logs/Xamarin-4.4/2017-05-03__16-53-36.19496.Broker.stderr.log...
Downloading /Users/Michael/Library/Logs/Xamarin-4.4/2017-05-03__16-53-36.19496.Build.log...
Downloading /Users/Michael/Library/Logs/Xamarin-4.4/2017-05-03__16-53-36.19496.Build.stderr.log...
Downloading /Users/Michael/Library/Logs/Xamarin-4.4/2017-05-03__16-53-36.19496.IDB.log...
Downloading /Users/Michael/Library/Logs/Xamarin-4.4/2017-05-03__16-53-36.19496.IDB.stderr.log...
Disconnected from the Mac McMinnie.local. (
Starting connection to Mac
Starting Broker in port 57455...
Connection successfully established with the Mac
Starting Agent Build
Connected to the Mac McMinnie.local. ( with Limited support.
Agent Build is running
Starting Agent IDB
Agent IDB is running
Connected to the Mac McMinnie.local. ( with Full support.

I tried with both Visual Studio 2015 and 2017 on Windows 10. Xamarin, Xamarin.iOS
The Mac has Xamarin Studio 6.3 (build 863), Xamarin.iOS

Both the Mac and Windows machine are wired to the same network and running the latest stable versions of Xamarin.

The problems seem to have started when I cloned the harddisk of my Mac Mini to a SSD and replaced the harddisk. But there are no other errors at all with the Mac. It is much faster than ever, the only problem is iOS deployment. So I don't think that it is related to that.
Comment 1 Michael Rumpler 2017-05-05 14:08:20 UTC
Created attachment 21977 [details]
Xamarin VS versions
Comment 2 Michael Rumpler 2017-05-05 14:08:55 UTC
Created attachment 21978 [details]
Xamarin versions on Mac
Comment 3 Michael Rumpler 2017-05-05 14:12:44 UTC
Created attachment 21979 [details]
Diagnostic build which failed

This is just one sample of a failed build. As I said, I get a different error every time I try to build+deploy.
Comment 4 Michael Rumpler 2017-05-09 10:10:48 UTC
Others have this problem too. See https://forums.xamarin.com/discussion/94356/unable-to-build-for-iphone-can-build-for-iphonesimulator
Comment 5 Jose Gallardo 2017-05-18 16:56:47 UTC
As per the comments in the forum thread, it seems to be a networking issue.
The connection got lost and that makes the build to fail.

Can you please confirm if that was the cause of the issue and if you was able to resolve it?

Comment 6 Michael Rumpler 2017-05-18 17:17:00 UTC
It was no networking issue. Both computers were wired to the same router.

But today it worked without problems.

I connect both the Mac and PC to one monitor with a KVM switch. The Mac was configured to sleep after 10mins. I switched from the Mac to Windows and immediately tried to build and got the error. When I configured the Mac to never sleep, the problem was gone. No idea if the Mac sleeps when you switch the monitor off (the power LED was still on).

I also updated VS on Windows and Mac. That could also have resolved it. Although I still saw the problem after the update and a reboot.
Comment 7 Danny Knoch 2017-10-12 07:22:33 UTC
This line:

"When I configured the Mac to never sleep, the problem was gone."

should be in huge letters in the trouble shooting guide.

I was facing an unstable connection to my mac build hosts for months. And my macs were also configured to sleep after 10 minutes and to go to sleep when the monitor goes offline. With this in mind, the "unstable" connection now totally makes sense.
It is not unstable, the macs just went to sleep, even when building the project.

Thank you very much for that info.

Someone should add that info to a more popular place. I was searching for that for months and it has been just a lucky coincidence to find this posts.