Bug 55887 - Native Linking Error with Firebase Remote Config
Summary: Native Linking Error with Firebase Remote Config
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components ()
Version: N/A
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Israel Soto [MSFT]
Depends on:
Reported: 2017-05-02 15:10 UTC by george
Modified: 2017-11-23 04:57 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description george 2017-05-02 15:10:45 UTC
I have a Xamarin.Forms project that I am working with.  I have added Firebase Remote Config to the Android portion of the project and it works fine.  When I add the Xamarin Firebase component for iOS, add a using statement for it and reference it in the AppDelegate, I get 20+ native linking errors.  I have tried to change settings I am seen online in different forums posts and nothing works.  I have also tried to create a new project from scratch.  Both the Xamarin.iOS and Xamarin.Forms (iOS) fail the same.  I have posted a question about this in the forums almost two weeks ago with no answer.  I have a project that is being held up by this issue.

I am using Firebase Remote Config for iOS from Xamarin Components.  I the attached example, all I did was create a new Xamarin.Forms PCL app, add the Firebase component, add the RemoteConfig line in AppDelegate.cs Line 17 and the using statement for Firebase.RemoteConfig.  I have 26 errors building as soon as I do this.  I am not sure that I selected the correct Component for this bug from the selections above.  

I have a sample application I can upload, but this is first bug logged and I am not sure where to add the code. Please let me know and I will happy to upload the code.

Any help with this would be greatly appreciated.

Thanks and looking forward to hearing a response.
Comment 1 Israel Soto [MSFT] 2017-05-23 17:53:21 UTC
Hi, George!

Can you upload your test case here?


Thanks in advance for your contribution!

Israel Soto.
Comment 2 Israel Soto [MSFT] 2017-11-23 04:57:42 UTC
I can reproduce the linker error with Firebase Remote Config for iOS v1.3.1.3 but it seems to be fixed on version