Bug 5579 - Delay in editor after deleting word with Ctrl-DEL
Summary: Delay in editor after deleting word with Ctrl-DEL
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: Trunk
Hardware: PC Linux
: Low normal
Target Milestone: (C7)
Assignee: Mike Krüger
Depends on:
Reported: 2012-06-08 05:25 UTC by Gavin
Modified: 2015-12-17 10:34 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Gavin 2012-06-08 05:25:31 UTC
Deleting a word with Ctrl-DEL while editing code causes the editor to not update for about a second, or until the next key is pressed.

(Tested in the standard C# editor, and in the D editor using the Mono-D addin.)
Comment 1 Gavin 2012-06-08 05:26:52 UTC
This behaviour appears to be related to the size of the codebase included in the solution -- it only happens for large projects.

I noticed this happening after upgrading to MonoDevelop 3.1.0.
Comment 2 Mike Krüger 2012-06-09 03:59:46 UTC
I can't repro it (linux mint).

Do you've a project where I can test it ? Which linux distribution are you using?

Tested on linux mint 13 cinnamon with monodevelop - which is a quite large solution.
Comment 3 Gavin 2012-06-11 05:28:04 UTC
The C# project I've experienced this with, for example, is the Mono-D addin: https://github.com/aBothe/Mono-D

I'm running ubuntu 12.04, but I also noticed this behaviour before with ubuntu 11.10 (I updated to 12.04 after installing monodevelop 3.1.0).

Looking at the monodevelop threads in htop, I see a very brief spike in CPU usage in one of the threads when pressing Ctrl-DEL. It's so brief though that it doesn't seem to account for the approximately one second delay I'm experiencing in the editor.
Comment 4 Mike Krüger 2012-10-09 06:52:32 UTC
I think that was fixed by the formatting engine - I've optimized it lately.
Comment 5 David Karlaš 2014-03-15 13:29:04 UTC
I ran into same problem on Windows. First while working on big file I noticed its a bit delayed.
But when I tried to reproduce on smaller sample I noticed following behaviour.
Start new instance of XS and create emptyTextFile type "a a a a a" now go to start of line/file and press 3x Ctrl+Del only 1st "a" will disappear. Now if you press key to move to right everything will be updated properly.
Comment 6 Marius Ungureanu 2014-03-15 14:02:52 UTC
Reopening bug report.
Comment 7 Mike Krüger 2015-05-18 01:13:10 UTC
Should be fixed in the roslyn version.
Comment 8 Jinjinov 2015-12-17 09:29:05 UTC
This delay still happens on Windows 7 on a C# project with 440 cs files and 46000 lines of code.
Comment 9 David Karlaš 2015-12-17 10:00:35 UTC
@Jinjinov, what version of Xamarin Studio are you using? You need 6.0 or newer. You are probably using 5.10.
You can get Preview of XS 6.0 at https://forums.xamarin.com/discussion/53121/preview-release-xamarin-studio-6-0-with-roslyn-support.

But I suggest you to wait few days for Preview 4 with many bug fixes compared to Preview 3 or just wait for official release of XS 6.0 which will be in beginning of next year.
Comment 10 Jinjinov 2015-12-17 10:28:30 UTC
@David Karlaš thank you for your swift reply!

I am using Xamarin Studio version 5.9.6 that is bound to Unity3D version 5.3 with a custom Unity plugin. The problem appeared on 8. December after upgrading from Unity3D version 5.2 which used MonoDevelop 4.0.12 that did not have this delay.

Surprisingly using Ctrl+Shift+RightArrow and then Delete deletes the same word without a delay.
Comment 11 David Karlaš 2015-12-17 10:34:08 UTC
XS 6.0 has many breaking API changes so it will probably take some time for Unity guys to update AddIn... That Shift+RightArrow is interesting workaround, hopefully it's not too much pain for you.

Happy coding,