Bug 55608 - Could not write lines to file ....csproj.FileListAbsolute.txt
Summary: Could not write lines to file ....csproj.FileListAbsolute.txt
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 7.1 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
Depends on:
Reported: 2017-04-26 07:52 UTC by Kent
Modified: 2017-04-27 20:14 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 55608 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Kent 2017-04-26 07:52:06 UTC
I'm aware that this issue has come up in the past, such as at https://bugzilla.xamarin.com/show_bug.cgi?id=36190. I can therefore only assume this is a regression.

With 15.1 (full version info below), I am frequently running into this problem. Android builds will stall with:

>Could not write lines to file "obj\Debug\Utility.csproj.FileListAbsolute.txt". The process cannot access the file 'C:\Users\Kent\Repository\xxx\Src\Utility\obj\Debug\Utility.csproj.FileListAbsolute.txt' because it is being used by another process. It's not always the same csproj file, though it is normally one of the "base" projects upon which lots of other projects depend.

My interim solution is to cancel the build, exit VS, do a git clean -xdf, then start VS again. Of course, this is incredibly annoying and time-consuming.

Strangely, I also see this warning output when doing iOS builds, but it just doesn't seem to stall the build there.

Full version info:

Microsoft Visual Studio Enterprise 2017 
Version 15.1 (26403.7) Release
Microsoft .NET Framework
Version 4.7.02046

Installed Version: Enterprise

Visual Basic 2017   00369-60000-00001-AA208
Microsoft Visual Basic 2017

Visual C# 2017   00369-60000-00001-AA208
Microsoft Visual C# 2017

Visual C++ 2017   00369-60000-00001-AA208
Microsoft Visual C++ 2017

Visual F# 4.1   00369-60000-00001-AA208
Microsoft Visual F# 4.1

Add New File   3.5
The fastest and easiest way to add new files to any project - including files that start with a dot

ASP.NET and Web Tools 2017   15.0.30320.0
ASP.NET and Web Tools 2017

ASP.NET Web Frameworks and Tools 2017   5.2.50303.0
For additional information, visit https://www.asp.net/

Azure App Service Tools v3.0.0   15.0.30209.0
Azure App Service Tools v3.0.0

Common Azure Tools   1.9
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

File Icons   2.6
Adds icons for files that are not recognized by Solution Explorer

HideMenu   1.0
Hides the Visual Studio main menu, similar to Windows Explorer and Internet Explorer

ILSpy.AddIn   1.0
Integration of the ILSpy Decompiler into Visual Studio.

JavaScript Language Service   2.0
JavaScript Language Service

JavaScript Project System   2.0
JavaScript Project System

JavaScript UWP Project System   2.0
JavaScript UWP Project System

KofePackagePackage Extension   1.0
KofePackagePackage Visual Studio Extension Detailed Info

Merq   1.1.17-rc (cba4571)
Command Bus, Event Stream and Async Manager for Visual Studio extensions.

Microsoft MI-Based Debugger   1.0
Provides support for connecting Visual Studio to MI compatible debuggers

Microsoft Visual Studio VC Package   1.0
Microsoft Visual Studio VC Package

Mono Debugging for Visual Studio   Mono.Debugging.VisualStudio
Support for debugging Mono processes with Visual Studio.

Continuous Testing Tool for .NET
Copyright © 2010-2016 Remco Software Ltd

NuGet Package Manager   4.1.0
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

OpenOnGitHub   1.3
Visual Studio Extension for opening files on GitHub.com

Rebracer   1.0
Saves editor formatting settings as part of each solution.

Snippet Designer   1.6.5
Snippet Designer is a Visual Studio plug in which allows you to create and search for snippets inside the IDE

SQL Server Data Tools   15.1.61702.140
Microsoft SQL Server Data Tools

Trailing Whitespace Visualizer   2.5.83
Keeps your code files clean by making it easier than ever to identify and remove any trailing whitespace

TypeScript tools for Visual Studio

Visual Studio Tools for Universal Windows Apps   15.0.26403.07
The Visual Studio Tools for Universal Windows apps allow you to build a single universal app experience that can reach every device running Windows 10: phone, tablet, PC, and more. It includes the Microsoft Windows 10 Software Development Kit.

VSColorOutput   2.5
Color output for build and debug windows - http://mike-ward.net/vscoloroutput

Xamarin (3f99c5a)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android SDK (b16fb82)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK (7656cc6)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2017-04-26 14:43:09 UTC
## Preliminary cross-referencing note

For recent appearances of symptoms involving *FileListAbsolute.txt, please see recent bug reports that mention FileListAbsolute.txt such as:

- Bug 54966
- Bug 54467

In particular, if you get a chance to try applying the change from Bug 54467, Comment 13, that might be a quick way to check if this is indeed a duplicate of Bug 54467.  Thanks!

Here's the information about that change for reference:

For VS2017:
Edit the C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\MSBuild\15.0\Microsoft.Common.Targets\ImportAfter\Xamarin.Common.targets

For VS2015:
Edit the C:\Program Files (x86)\MSBuild\14.0\Microsoft.Common.Targets\ImportAfter\Xamarin.Common.targets

(you'll need to be an administrator to edit either one)

Update the `GetBuiltProjectOutputRecursive` Target to contain the following nodes instead of the current ones:

			<_GetBuiltOutputProject Include="@(_MSBuildProjectReferenceExistent)"
									Condition="$(_BuiltProjectOutputs.Contains('%(_MSBuildProjectReferenceExistent.FullPath)')) == 'false'" />

			<!-- Add all the top-level projects that will be added by the @(BuiltProjectOutputGroupKeyOutput) further below -->
			<_BuiltProjectOutputs>$(_BuiltProjectOutputs)|$(MSBuildProjectFullPath)|@(_MSBuildProjectReferenceExistent->'%(FullPath)', '|')</_BuiltProjectOutputs>
Comment 2 Jeremy Kolb 2017-04-27 14:30:14 UTC
I'm seeing this building Example.Droid project from the MvvmCross repo located here: https://github.com/MvvmCross/MvvmCross.

Comment 3 Jeremy Kolb 2017-04-27 14:40:33 UTC
Brendan Zagaeski

I tried the workaround from C1 above and it did not fix my problem.
Comment 4 Jeremy Kolb 2017-04-27 14:53:51 UTC
Sorry I see it when *deploying* that project (you have to go into the solution configuration and enable deploy for that project).  It reproduces every time.
Comment 5 Jeremy Kolb 2017-04-27 20:03:43 UTC
@Brendan Zagaeski

I just tried turning Fast Deployment off and now it seems to work.
Comment 6 Jeremy Kolb 2017-04-27 20:07:36 UTC
Correction: Turning off Fast Deployment only worked the first time.
Comment 7 Jeremy Kolb 2017-04-27 20:14:55 UTC
Ok more info:

Turning off Fast Deployment once allowed the build to deploy.  The next time it failed to deploy.  I then went in and TOGGLED Fast Deployment on and then off again and it deployed again.  This is repeatable.

So to sum it up:  when I hit this I go into the project settings and toggle Fast Deployment to checked and then to unchecked and it gets me past this issue.