Bug 55582 - error XBD009: Partial Download Failed for one or more parts
Summary: error XBD009: Partial Download Failed for one or more parts
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- major
Target Milestone: ---
Assignee: Jon Dick
Depends on:
Reported: 2017-04-25 18:16 UTC by Sid Dubey
Modified: 2017-09-28 14:46 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Comment 1 dean.ellis 2017-04-27 11:57:16 UTC
Jonathan, Looks like a bug in the Downloader
Comment 2 Jon Dick 2017-04-27 12:30:24 UTC
The problem I'm guessing is that the proxy in use does not support HTTP range requests which is a prerequisite currently for Xamarin.Build.Download to download the dependencies (without downloading the entire file).

We discussed this as a potential issue and the work around being to follow the instructions in the error message and install the items in the Android SDK manually.
Comment 3 Jon Dick 2017-04-27 13:10:40 UTC
I'm going to close this issue as it's not something on our roadmap currently.  There are some other plans to manage SDK downloads which should eventually obsolete this.  For now the workaround is to install the item in the Android SDK manager manually as per the error message.
Comment 4 Jason Rawlins 2017-04-27 14:45:35 UTC
Unfortunately @Jon.Dick those instructions don't appear to work. They worked for the older components but they don't work with the current ones. Yes, there is a work around but I would suggest the document be updated highlighting the new location and how to construct the folder..

Windows works with no issues... the problem is with the Mac, they both go through the same proxy... Looks to me like the Mac isn't even attempting to connect through the proxy when downloading the dependencies..
Comment 5 Jon Dick 2017-04-27 15:37:37 UTC
With Xamarin.Build.Download and the Android Support libs that depend on it, there shouldn't be any special requirements for the workaround other than to make sure you've installed the correct item in the Android SDK Manager.

The one caveat with this is you need to make sure you're using the same Android SDK Manager for the Android SDK that Xamarin.Android is building with.  

If this is not working, there may be a bug with Xamarin.Build.Download.  Could you check the contents of your `$ANDROID_HOME/extras/android/m2repository/` ?  you should for instance see:


If you have the latest version of the "Extras -> Android Support Repository" installed in the Android SDK Manager.
Comment 6 Jason Rawlins 2017-04-27 17:07:37 UTC
I can confirm I have all the expected files in the appcompat-v7 folder..

My work around was:

When I connected my Mac to a hotspot (bypass proxy) and started a build a folder got created in ~/Library/Caches/XamarinBuildDownload called androidsupport-25.1.1 (25.3.1 wasn't available at the time) Needless to say the build succeeded. When I moved back behind the proxy, the build still succeeded.

When I renamed the folder and tried the build again it fails with the same error as before..

I copied this folder to our build server to and it successfully built..

So, something is not quite right...
Comment 7 Jon Dick 2017-05-17 14:08:55 UTC
Right, so it's not finding your local SDK manager copy.

Can you attach some diagnostic output msbuild logs from it failing when you're behind the proxy?
Comment 8 Jon Dick 2017-09-28 14:29:51 UTC
Newer versions of android support use a different download mechanism (or no download mechanism), so this issue is no longer relevant.