Bug 55 - SIGSEGV with basic 'universal window-based project'
Summary: SIGSEGV with basic 'universal window-based project'
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: 4.x
Hardware: Macintosh Mac OS
: --- blocker
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2011-07-24 16:30 UTC by NicoDG
Modified: 2011-08-18 01:59 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Test case (1.30 MB, application/zip)
2011-07-27 18:41 UTC, Rolf Bjarne Kvinge [MSFT]

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description NicoDG 2011-07-24 16:30:48 UTC
- Create a new 'universal window-based project' C# iPad and iPhone solution
- Add a textbox to the window
- Debug & run
- Enter a number (not any other character) in the textbox
--> terminates SIGSEGV

Sample in attachment
Comment 1 Chris Toshok 2011-07-25 08:28:55 UTC
There's no attachment.  Could you attach it?
Comment 2 Rolf Bjarne Kvinge [MSFT] 2011-07-27 13:49:00 UTC
I just tried this according to the instructions, and it doesn't crash. Can you attach the sample project?
Comment 3 Rolf Bjarne Kvinge [MSFT] 2011-07-27 18:41:56 UTC
Created attachment 26 [details]
Test case
Comment 4 Rolf Bjarne Kvinge [MSFT] 2011-07-27 18:42:39 UTC
I tried the test case, but it doesn't crash for me. Have you tried with the recently released MonoTouch
Comment 5 NicoDG 2011-07-28 01:19:58 UTC
Yes, I installed a few days ago, but still have the issue.

Did you try the test case on the new Mac OS Lion?
Comment 6 Miguel de Icaza [MSFT] 2011-07-29 17:06:46 UTC
I can not reproduce this on Lion with either the simulator or the device.
Comment 7 NicoDG 2011-08-18 01:59:23 UTC
Resolved after installing the latest Montouch update