Bug 54288 - Xamarin.UITest fails to start with DeviceAgentException after upgrading to Xcode 8.3
Summary: Xamarin.UITest fails to start with DeviceAgentException after upgrading to Xc...
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2017-03-30 12:49 UTC by leankitryan
Modified: 2017-04-10 22:28 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description leankitryan 2017-03-30 12:49:51 UTC
After upgrading to Xcode 8.3 and Xamarin Cycle 9 SR0 with XCode 8.3 support, I can no longer run Xamarin UITests locally on any iOS hardware device. The test fails to start with the error:

  SetUp : Calabash.XDB.Core.Exceptions.DeviceAgentException : Failed to install DeviceAgent

  ExitCode: 134

Similarly, iOS 10 simulator tests fail with an error before starting:

  SetUp : Calabash.XDB.Core.Exceptions.DeviceAgentException : Failed to install DeviceAgent

  ExitCode: 5

  -a,--app-bundle <path/to/app-bundle.app> Path .app bundle (for .ipas, unzip and look inside of 'Payload')-c,--codesign-identity <codesign-identity> [OPTIONAL] Identity used to codesign app bundle [device only] DEFAULT=-d,--device-id <device-identifier> iOS Simulator GUIDs-u,--update-app <true-or-false> [OPTIONAL] When true, will reinstall the app if the device contains an older version than the bundle specified DEFAULT=1installError installing com.apple.test.DeviceAgent-Runner to F56A011E-BEF3-4E62-8FBC-42FA44F99076: Error Domain=com.facebook.FBSimulatorControl Code=0 "Simulator does not support any of the architectures ([x86_64, i386]) of the executable at /var/folders/b8/t_kfyfk90w3dpdwjqsxfrdp40000gn/T/xdb/DeviceAgent.iOS.Dependencies/54daf9e58e37a80353a99c2b3139b615/app/DeviceAgent-Runner.app/XCTRunner. Simulator Archs ([(null)])" UserInfo={NSLocalizedDescription=Simulator does not support any of the architectures ([x86_64, i386]) of the executable at /var/folders/b8/t_kfyfk90w3dpdwjqsxfrdp40000gn/T/xdb/DeviceAgent.iOS.Dependencies/54daf9e58e37a80353a99c2b3139b615/app/DeviceAgent-Runner.app/XCTRunner. Simulator Archs ([(null)])}false


iOS 9 Simulators do however still work.

I have tried the latest stable Xamarin.UITest package, 2.0.7 and also the latest pre-release dev version, same result. Our iOS project is using the latest Xamarin.TestCloud.Agent version from NuGet, 0.20.3. 

=== Xamarin Studio Professional ===

Version 6.2.1 (build 3)
Installation UUID: 605daac9-8c37-4142-8ffa-8f712a557af8
	Mono 4.8.0 (mono-4.8.0-branch/8f6d0f6) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 408000520

=== NuGet ===


=== Xamarin.Profiler ===

Version: 1.2.1
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Xamarin.Android ===

Version: (Visual Studio Professional)
Android SDK: /Users/ryan/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
		6.0    (API level 23)
		7.0    (API level 24)
		7.1    (API level 25)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 25.0.3
SDK Build Tools Version: 25.0.2

Java SDK: /usr
java version "1.8.0_102"
Java(TM) SE Runtime Environment (build 1.8.0_102-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.102-b14, mixed mode)

Android Designer EPL code available here:

=== Xamarin Android Player ===

Not Installed

=== Apple Developer Tools ===

Xcode 8.3 (12169)
Build 8E162

=== Xamarin.Mac ===

Not Installed

=== Xamarin.iOS ===

Version: (Visual Studio Professional)
Hash: e66c6f19
Branch: xcode8.3
Build date: 2017-03-28 00:48:33-0400

=== Xamarin Inspector ===

Not Installed

=== Xamarin Inspector ===

Hash: dc081aa
Branch: master
Build date: Tue Apr 26 23:07:44 UTC 2016

=== Build Information ===

Release ID: 602010003
Git revision: 5217903c99e9d9c5d3caa2498fd66d607debac29
Build date: 2017-03-23 12:36:46-04
Xamarin addins: 2c96d252b353fce2e8b8fd20884eee70c16c7f32
Build lane: monodevelop-lion-cycle9

=== Operating System ===

Mac OS X 10.12.3
Darwin leankitryan-mbp-2.local 16.4.0 Darwin Kernel Version 16.4.0
    Thu Dec 22 22:53:21 PST 2016
    root:xnu-3789.41.3~3/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

NuGet Package Explorer 0.1
NuGet Package Management Extensions 0.12
Redth's Addins 1.0.7
Xamarin Inspector
Comment 1 John Miller [MSFT] 2017-03-30 13:00:27 UTC
Xcode 8.3 is not yet supported with UITest. It's being actively worked on to bring support ASAP. 

The latest release notes will contain information on the next version to suppor this: https://developer.xamarin.com/releases/testcloud/uitest/