Bug 542 - Unknown Member
Summary: Unknown Member
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 1.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2011-08-30 11:39 UTC by kimarov
Modified: 2011-09-07 10:55 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Unknown Member - Attachment (5.49 MB, application/octet-stream)
2011-08-31 00:33 UTC, kimarov

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description kimarov 2011-08-30 11:39:58 UTC
I have been trying to consume my web service with a monodroid application but I keep on getting error message saying "Unknown Member". I tried to run the sample application from this URL; http://android.xamarin.com/index.php?title=Documentation/Guides/Consuming_Web_Services&file=58, but I keep on getting the same error and here it says 'unknown member: Invoke' and it occurs on the method below of the web service http://soatest.parasoft.com/calculator.wsdl

public float add(float x, float y) 
object[] results = this.Invoke("add", new object[] { x, y}); 
return ((float)(results[0])); 
Comment 1 kimarov 2011-08-30 11:41:14 UTC
I am using Windows XP professional SP3
Comment 2 Jonathan Pobst 2011-08-30 21:47:58 UTC
The tutorial works for me.  Can you zip up your project that doesn't work and attach it to this bug?
Comment 3 kimarov 2011-08-31 00:33:05 UTC
Created attachment 219 [details]
Unknown Member - Attachment

The attached project produces the error; 'Unknown Member: Invoke'
Comment 4 Jonathan Pryor 2011-08-31 16:16:21 UTC
I'm not able to reproduce this either.

I extracted FirstApp.rar, and installed the provided bin/Debug/FirstApp.FirstApp-Signed.apk file. It runs on my N1 without any runtime errors . What device are you running on?
Comment 5 Jonathan Pryor 2011-08-31 21:56:44 UTC
Doubly interesting is that, normally, the linker is only involved in Release builds, and FirstApp.rar does not contain a bin/Release directory (i.e. no Release build). As such, any bug wouldn't be a linker bug (Debug builds don't link).
Comment 6 Jonathan Pobst 2011-08-31 21:57:40 UTC
Debug builds can be set to link.  If you look at the project properties, it is set to link for the Debug configuration.
Comment 7 Jonathan Pobst 2011-09-07 10:55:02 UTC
Working on this one through the support channel, the issue was an incorrect IP address.  Marking as RESOLVED.