Bug 53171 - Inspector does not install
Summary: Inspector does not install
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Inspector Integration ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: xamarininteractive
Depends on:
Reported: 2017-03-08 22:58 UTC by Kent
Modified: 2017-09-08 16:48 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

VSIX installation log (4.08 KB, text/plain)
2017-03-08 22:58 UTC, Kent
Version Info (4.80 KB, text/plain)
2017-03-08 22:59 UTC, Kent
Android CSPROJ (93.79 KB, text/plain)
2017-03-08 23:16 UTC, Kent
iOS CSPROJ (76.41 KB, text/plain)
2017-03-08 23:16 UTC, Kent
Android debug output (286.07 KB, text/plain)
2017-03-09 00:43 UTC, Kent
Inspector log (28 bytes, text/plain)
2017-03-09 00:44 UTC, Kent

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Kent 2017-03-08 22:58:26 UTC
Created attachment 20221 [details]
VSIX installation log

The Inspector button was missing from my VS despite having the latest version of Workbooks working. I tried re-installing but that didn't help. I therefore went hunting about for the VSIX and found it at C:\Program Files (x86)\Xamarin\Workbooks\VisualStudioExtension\Xamarin.Interactive.VS.vsix. However, when I try and run it I get "Installation Failed". I've attached the log as well as version info.
Comment 1 Kent 2017-03-08 22:59:08 UTC
Created attachment 20222 [details]
Version Info
Comment 2 Sandy Armstrong [MSFT] 2017-03-08 23:05:30 UTC
What version of Xamarin for Visual Studio do you have installed?

Starting with Xamarin for VS 4.3, the Inspector extension is actually bundled with the rest of Xamarin. You still have to install Workbooks+Inspector to get the client, though (which you've already done). The VSIX you found is only installed if Xamarin for VS 4.2 is present.

If you have Xamarin for VS 4.3 or newer, you won't see the Inspector extension listed separately in About Visual Studio anymore. You also won't see the old Xamarin Inspector toolbar. We now dynamically add the button in the debug toolbar (with the pause/step buttons). And you will only see the button if you are currently debugging a project that is supported by Xamarin Inspector.

Visual Studio Enterprise is also required, but judging from the attached log it seems you have that.

After you've confirmed the version of Xamarin for Visual Studio installed, it would also be helpful to know what kind of project you are testing. Can you attach the csproj?
Comment 3 Sandy Armstrong [MSFT] 2017-03-08 23:06:40 UTC
Okay, I see we collided. Thanks for attaching the version info! Still setting to NEEDINFO for the csproj information.
Comment 4 Kent 2017-03-08 23:15:26 UTC
Thanks for a prompt follow-up, Sandy.

Ah, so I was following the instructions here https://developer.xamarin.com/guides/cross-platform/inspector/inspect/ and was looking for the "Inspect current app" menu item under Tools. It's not listed anywhere.

I neglected to even look in the toolbar. I do see a little inspector icon there, but it's disabled for both iOS and Android.

Will attach the CSPROJ presently.
Comment 5 Kent 2017-03-08 23:16:00 UTC
Created attachment 20224 [details]
Android CSPROJ
Comment 6 Kent 2017-03-08 23:16:24 UTC
Created attachment 20225 [details]
Comment 7 Kent 2017-03-08 23:16:35 UTC
Info provided.
Comment 8 Sandy Armstrong [MSFT] 2017-03-08 23:35:32 UTC
Those instructions need to be updated for Xamarin 4.3. Thanks for noticing. Since the button moved to the debug toolbar, the menu item moved to the debug menu as well.

Can you please attach both:
* %LOCALAPPDATA%\Xamarin\Logs\{VS version}\Inspector {date}.log
* A copy of the contents of the Output pane when you are debugging your app

General questions:
* You are running VS2015 Enterprise, yes?
* You are definitely in debug configuration, and not release?
* Do you have multiple startup projects? We don't support that well at this time.

For Android:
* What kind of device are you deploying to?
  - Google, VS, or Xamarin emulator?
  - What version of Android is it running?
  - x86 or ARM?

For iOS:
* Which sim device are you deploying to?
* Do you have the same version of Workbooks+Inspector installed on the Mac build host? At this time, we still require that.
Comment 9 Kent 2017-03-09 00:42:39 UTC
Ooooh, I didn't realize it was a separate install on Mac. Just did that and now the inspector works for iOS!

However, still not working on Android...

> You are running VS2015 Enterprise, yes?


> You are definitely in debug configuration, and not release?

Yes, debug.

> Do you have multiple startup projects? We don't support that well at this time.


> What kind of device are you deploying to?

Nexus 5.

> What version of Android is it running?


> x86 or ARM

Comment 10 Kent 2017-03-09 00:43:34 UTC
Created attachment 20231 [details]
Android debug output
Comment 11 Kent 2017-03-09 00:44:02 UTC
Created attachment 20232 [details]
Inspector log
Comment 12 Kent 2017-03-09 00:44:17 UTC
Info provided.
Comment 13 Sandy Armstrong [MSFT] 2017-03-09 02:11:51 UTC
OK, I'll have to double-check, but it seems we're not verifying that the device is an emulator, which is why you see the Inspect button disabled (indicating it's trying to connect) instead of enabled (and then providing a helpful error message when you click).

You cannot inspect Android app deployed to physical devices at this time. You must use an emulator, and it must be x86.

I recommend Google's Android emulator, with HAXM. If you are on a system where you must have Hyper-V enabled, then use Visual Studio's Android emulator.

Sorry for the issues you've run into. Definitely there are some things we missed checking, and should be able to show error messages to the user in these cases.
Comment 14 Kent 2017-03-09 02:29:32 UTC
Ah, OK. That makes sense.

On that note, I do use VS Android emulator but avoid it due to a long-standing issue whereby it uses 100% of one CPU core when it runs. Non-stop.

Can I raise a BZ against the Visual Studio Extensions component for this? Or is it (as I suspect) owned by someone else entirely?
Comment 15 Sandy Armstrong [MSFT] 2017-03-09 04:31:46 UTC
Visual Studio Android Emulator is owned by a different part of Microsoft. I do not know if they have a public bug tracker.

I've also had several issues with it, some of which are documented here: https://developer.xamarin.com/guides/cross-platform/workbooks/troubleshooting/ .

That's why I always recommend the Google emulator when you can afford to turn off Hyper-V and install HAXM. It runs very fast now.

It's possible that one day we could support inspecting apps that are deployed to your physical device (even if it's ARM), so that you don't have to worry about emulators at all, but it's not currently being worked on.
Comment 16 Sandy Armstrong [MSFT] 2017-05-02 16:28:12 UTC
Documentation has been updated. We have other bugs to track dealing with physical devices, and removing the requirement to have Workbooks+Inspector installed on mac build hosts for iOS inspection.

Resolving this bug.