Bug 53154 - Banshee does not start with Mono 4.8 due to a dbus issue
Summary: Banshee does not start with Mono 4.8 due to a dbus issue
Status: NEW
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: 4.8.0 (C9)
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2017-03-08 13:57 UTC by Timotheus Pokorra
Modified: 2017-06-12 12:32 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 53154 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Timotheus Pokorra 2017-03-08 13:57:06 UTC
There seem to be various reports about Banshee working fine with Mono 4.6 but failing to start with Mono 4.8:

for example:

System.MethodAccessException: Method `IBusProxy:.ctor ()' is inaccessible from method `NDesk.DBus.BusObject:.ctor()

for full stacktrace see https://bugzilla.redhat.com/attachment.cgi?id=1257070

Is it a bug?
Is it an incompatibility with a dbus package?
Comment 1 martadinata666 2017-03-24 00:31:14 UTC
also got error, and reproduceable

[ERROR] FATAL UNHANDLED EXCEPTION: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.MethodAccessException: Method `IBusProxy:.ctor ()' is inaccessible from method `NDesk.DBus.BusObject:.ctor ()'
Comment 2 Alexander Ivanov 2017-04-11 07:33:29 UTC
Got same error with other project using NDesk.DBus.dll
Comment 3 Ondrej Myska 2017-06-12 12:32:25 UTC
Same error on Mono (custom arm build), but I think it is not a Mono issue.


if (declType.IsInterface)
  parentType = typeof (BusObject);
  parentType = declType;

TypeBuilder typeB = modB.DefineType (proxyName, TypeAttributes.Class | TypeAttributes.Public, parentType);

if declaring type is interface, parentType is set to BusObject type which has default (internal) accessibility.
The root of issue is you try to construct public type with base type with default (internal) accessibility.

Mono prior to version 4.8 had probably issue which was fixed and it brakes NDesk.DBus.dll.