Bug 53109 - [Mac Xamarin Studio Community] Mono Crashes when Dealing with Notifications on Android
Summary: [Mac Xamarin Studio Community] Mono Crashes when Dealing with Notifications o...
Status: NEW
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger ()
Version: 4.8.0 (C9)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
Depends on:
Reported: 2017-03-07 12:00 UTC by kyluke.m
Modified: 2018-02-07 16:08 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 53109 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description kyluke.m 2017-03-07 12:00:01 UTC
OS: Mac Sierra 10.12.3 (16D32)

Xamarin Studio Community Edition: 6.2.0
Xamarin Forms:
Xamarin Android:

Mono Framework:

GCM Notification comes through on the device. User taps on notification and app crashes with error code:

[ToolbarWidgetWrapper] Progress display unsupported
[] * Assertion at /Users/builder/data/lanes/4009/f3074d2c/source/mono/mono/mini/debugger-agent.c:8732, condition `locals->locals [i].index < header->num_locals' not met
[libc] Fatal signal 6 (SIGABRT), code -6 in tid 1843 (Debugger agent)
Comment 1 kyluke.m 2017-03-22 13:34:00 UTC
I've downgraded to Mono 4.6.2 and it's still happening. This time on iOS builds.

This the error message, uninstalling the app from the device has not worked. Cleaning and rebuilding also has not worked.

2017-03-22 15:21:25.829 <redactedAppName>[438:388359] error: * Assertion at /Users/builder/data/lanes/4466/f94cf268/source/xamarin-macios/external/mono/mono/mini/debugger-agent.c:8732, condition `locals->locals [i].index < header->num_locals' not met
2017-03-22 15:21:25.830 <redactedAppName>[438:388359] critical: Stacktrace:

2017-03-22 15:21:25.830 <redactedAppName>[438:388359] critical: 
Native stacktrace:

2017-03-22 15:21:26.143 <redactedAppName>[438:388359] critical: 	0   <redactedAppName>                             0x00000001000e1d5c mono_handle_native_sigsegv + 260
2017-03-22 15:21:26.144 <redactedAppName>[438:388359] critical: 	1   libsystem_platform.dylib            0x0000000191981348 _sigtramp + 52
2017-03-22 15:21:26.144 <redactedAppName>[438:388359] critical: 	2   libsystem_pthread.dylib             0x0000000191987450 pthread_kill + 112
2017-03-22 15:21:26.144 <redactedAppName>[438:388359] critical: 	3   libsystem_c.dylib                   0x0000000191833400 abort + 140
2017-03-22 15:21:26.145 <redactedAppName>[438:388359] critical: 	4   <redactedAppName>                             0x00000001001d284c _ZL12log_callbackPKcS0_S0_iPv + 76
2017-03-22 15:21:26.145 <redactedAppName>[438:388359] critical: 	5   <redactedAppName>                             0x00000001001cc180 monoeg_g_logv + 100
2017-03-22 15:21:26.145 <redactedAppName>[438:388359] critical: 	6   <redactedAppName>                             0x00000001001cc374 monoeg_assertion_message + 44
2017-03-22 15:21:26.146 <redactedAppName>[438:388359] critical: 	7   <redactedAppName>                             0x00000001000d55f4 method_commands_internal + 13248
2017-03-22 15:21:26.146 <redactedAppName>[438:388359] critical: 	8   <redactedAppName>                             0x00000001000c43ac debugger_thread + 4672
2017-03-22 15:21:26.146 <redactedAppName>[438:388359] critical: 	9   <redactedAppName>                             0x00000001001c2f74 inner_start_thread + 320
2017-03-22 15:21:26.147 <redactedAppName>[438:388359] critical: 	10  libsystem_pthread.dylib             0x0000000191985850 <redacted> + 240
2017-03-22 15:21:26.148 <redactedAppName>[438:388359] critical: 	11  libsystem_pthread.dylib             0x0000000191985760 <redacted> + 0
2017-03-22 15:21:26.148 <redactedAppName>[438:388359] critical: 	12  libsystem_pthread.dylib             0x0000000191982d94 thread_start + 4
2017-03-22 15:21:26.149 <redactedAppName>[438:388359] critical: 
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
Comment 2 kyluke.m 2017-03-22 13:40:15 UTC
This problem does not seem to exist when using the simulators. I've only experienced the issue on a physical device.
Comment 3 kyluke.m 2017-03-23 05:19:39 UTC
Downgrading to Cycle 8 has solved the problem. This is definitely an issue with cycle 9.
Comment 4 bemnet4u 2017-09-18 06:54:50 UTC
I also get the same crash on my mac/andoird device. Please help!!!

Visual Studio Enterprise 2017 for Mac
Version 7.1 (build 1297)
	Mono (d15-3/da80840) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 502000215

I also see the same problem when testing on physical device 

Version: (Visual Studio Enterprise)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 25.0.5
SDK Build Tools Version: 25.0.3