Bug 52890 - The "OverrideToolHost" parameter is not supported by the "Csc" task.
Summary: The "OverrideToolHost" parameter is not supported by the "Csc" task.
Alias: None
Product: Tools
Classification: Mono
Component: msbuild ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Ankit Jain
Depends on:
Reported: 2017-02-28 09:49 UTC by Marek Safar
Modified: 2017-03-08 02:53 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Marek Safar 2017-02-28 09:49:12 UTC
1. clone CoreFX repo
2. msbuild /p:BuildConfiguration=netstandard1.1

/Users/marek/git/dotnet/corefx/Tools/Microsoft.CSharp.Core.targets(106,11): error MSB4064: The "OverrideToolHost" parameter is not supported by the "Csc" task. Verify the parameter exists on the task, and it is a settable public instance property. [/Users/marek/git/dotnet/corefx/src/Tools/CoreFx.Tools/CoreFx.Tools.csproj]
/Users/marek/git/dotnet/corefx/Tools/Microsoft.CSharp.Core.targets(67,5): error MSB4063: The "Csc" task could not be initialized with its input parameters.  [/Users/marek/git/dotnet/corefx/src/Tools/CoreFx.Tools/CoreFx.Tools.csproj]
Comment 1 Ankit Jain 2017-03-02 12:50:48 UTC
I can't find any reference to `OverrideToolHost` in Roslyn. I tried to build with `./build.sh` which fetches the tools but couldn't find any `OverrideToolHost` references.
Comment 2 Marek Safar 2017-03-02 13:11:35 UTC
you don't need to call ./build.sh

What happen when you did step 2 `msbuild /p:BuildConfiguration=netstandard1.1` ?
Comment 3 Ankit Jain 2017-03-02 15:18:12 UTC
I tried again with a clean checkout:

$ msbuild /p:BuildConfiguration=netstandard1.1

"/Users/ankit/dev/corefx/build.proj" (default target) (1) ->
  /Users/ankit/dev/corefx/build.proj(29,3): error MSB4019: The imported project "/Users/ankit/dev/corefx/Tools/clean.targets" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk.

There is no `Tools/` directory, only a `Tools-Override` but no `Tools-Override/clean.targets` .

I ran `init-tools.sh` and that populated `Tools` and that does have a `Microsoft.CSharp.Core.targets` and `Tools/Microsoft.Build.Tasks.CodeAnalysis.dll` which has a `Csc.OverrideToolHost` property.

A patched copy of the msbuild tasks and targets seems to be in use here. Try the `Tools/msbuild.sh` script instead.
Comment 4 Marek Safar 2017-03-02 15:36:40 UTC
That seems to fix the problem
Comment 5 Ankit Jain 2017-03-08 02:53:28 UTC