Bug 52683 - Failed to resolve reference after building example solution
Summary: Failed to resolve reference after building example solution
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.2
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Paul DiPietro [MSFT]
Depends on:
Reported: 2017-02-22 19:10 UTC by Chase Long
Modified: 2017-04-12 21:38 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Chase Long 2017-02-22 19:10:41 UTC
I have a production app that uses Xamarin.Forms 2.3.27 on Android and iOS. The iOS project no longer builds after downloading, building, and running the Validation Callback sample from https://developer.xamarin.com/samples/xamarin-forms/XAML/ValidationCallback/. The build now fails with this error:

Failed to resolve "System.Void Xamarin.Forms.Xaml.Internals.SimpleValueTargetProvider::.ctor(System.Object[],System.Object)" reference from "Xamarin.Forms.Xaml, Version=, Culture=neutral, PublicKeyToken=null"
Comment 2 Chase Long 2017-02-22 19:37:32 UTC
I worked around this by deleting the Xamarin.Forms package, restoring it through NuGet, and rebuilding my solution.
Comment 3 Paul DiPietro [MSFT] 2017-02-22 19:40:52 UTC
I was in the midst of asking about that when you commented -- I'm expecting that something went awry and cleaning/rebuilding would resolve it (as it can often do). I'll set this as resolved for now and if you consistently run into the issue in the future with specific issues, it might be worth reopening to have one of the other teams look at.
Comment 4 Chase Long 2017-02-22 19:44:45 UTC
Paul, FYI in case this changes how you want to handle this one: I tried doing a clean in Visual Studio and multiple rebuilds in VS before deleting the package. None of those helped.