Bug 52669 - Xamarin inspector not loading
Summary: Xamarin inspector not loading
Alias: None
Product: Workbooks & Inspector
Classification: Xamarin
Component: Client: Visual Inspector ()
Version: 1.1.1
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: xamarininteractive
Depends on:
Reported: 2017-02-22 16:29 UTC by Alvaro Rivoir
Modified: 2017-02-22 18:39 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Log file (165.05 KB, text/plain)
2017-02-22 17:31 UTC, Alvaro Rivoir

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Alvaro Rivoir 2017-02-22 16:29:45 UTC
When loading Xamarin Inspector, which opens Xamarin workbooks, I'm getting this exception "Could not load file or assembly 'Xamarin.Interactive.Wpf'"
Comment 1 Sandy Armstrong [MSFT] 2017-02-22 16:47:55 UTC
Can you give exact steps? I don't know what you mean by "loading Xamarin Inspector".

Can you attach your log file from:
   %LOCALAPPDATA%\Xamarin\Inspector\logs\Xamarin Inspector {date}.log

What version of Windows are you using?
Comment 2 Alvaro Rivoir 2017-02-22 17:13:31 UTC
It just fail when it's open, you only have to open it. Clicking in Visual studio inspector icon.

Windows 10.0.19393
Comment 3 Sandy Armstrong [MSFT] 2017-02-22 17:20:17 UTC
Thanks. Can you please attach the log file as well?
Comment 4 Alvaro Rivoir 2017-02-22 17:31:58 UTC
Created attachment 19905 [details]
Log file
Comment 5 Sandy Armstrong [MSFT] 2017-02-22 17:40:22 UTC
Alvaro, do you have Inspector/Workbooks 1.1.1 installed on your Mac build host?

The version installed on Mac and Windows must match exactly.

We are improving this in a future release, but for today, you need to keep them in sync.
Comment 6 Alvaro Rivoir 2017-02-22 17:47:52 UTC
No, it's not the same version. I tried to update the mac app but there is no "install" button, only "skip this version", "remember later" or "Learn more..." which drives you to a 404 broken link. How it is it supposed to work?
Comment 7 Sandy Armstrong [MSFT] 2017-02-22 17:58:09 UTC
The symptoms you describe show that you have 1.0 installed on Mac, not 1.1.1.

That 404 is something we need to fix. Thanks for pointing it out. I will get the web team to fix the redirect.

You can download and install 1.1.1 from https://dl.xamarin.com/interactive/XamarinInteractive-
Comment 8 Alvaro Rivoir 2017-02-22 18:28:11 UTC
Updating the mac app worked. Please fix the windows client to alert about a different version. It's frustrating using a tool that stop working when you update it.
Comment 9 Sandy Armstrong [MSFT] 2017-02-22 18:31:57 UTC

Yes, we are fixing the experience here. Sorry for the trouble.
Comment 10 Sandy Armstrong [MSFT] 2017-02-22 18:39:16 UTC
And as a general note, the redirect on the Learn More button is now fixed as well, so auto-updates from 1.0 will work again.