Bug 52531 - [FirstRun] Install Missing Features dialog pops up when Xamarin is already installed for some .sln
Summary: [FirstRun] Install Missing Features dialog pops up when Xamarin is already in...
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 4.2.0 (C8)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2017-02-15 17:44 UTC by Jon Douglas [MSFT]
Modified: 2017-06-19 12:45 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

IDE/Platform Logs (1.08 KB, application/x-zip-compressed)
2017-02-15 17:44 UTC, Jon Douglas [MSFT]

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Jon Douglas [MSFT] 2017-02-15 17:44:02 UTC
Created attachment 19827 [details]
IDE/Platform Logs


The Install Missing Features dialog will pop up even when Xamarin has already been installed by the user for some .sln files. Here is an example of opening the solution in the following project:



Although I haven't figured out the direct cause here, it seems to be related to how these .sln projects are setup(and the paths to the .csproj).

This has left some customers extremely confused as they already have installed Xamarin and then they might try to repair their installation due to this bug. This dialog will no longer present itself once the .vs cache is created. However it still doesn't load .csproj that include parts of the Xamarin Platform.

*Version Information:

Microsoft Visual Studio Professional 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01586

Installed Version: Professional

Xamarin (00fa5cc)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin Inspector Support (1f3067d)
Adds support for inspecting Xamarin and WPF apps.

Xamarin.Android (501e63c)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS (7beaef4)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 1 thomas 2017-02-17 16:35:18 UTC
Yeah, I'm one of these customers and I really need be able to open the referenced solution to debug my App using FirebaseMessaging.

So any workaroung would be great
Comment 2 Daniel Cazzulino 2017-04-06 16:06:42 UTC
Downloaded the ZIP from the repo, as instructed, I run `powershell .\build.ps1 -Target libs` and get:


Preparing to run build script...
Test-Path : Cannot bind argument to parameter 'Path' because it is an empty string.
At C:\Delete\GooglePlayServicesComponents-master\build.ps1:99 char:70
+ ... $existingPaths = $Env:Path -Split ';' | Where-Object { Test-Path $_ }
+                                                                      ~~
    + CategoryInfo          : InvalidData: (:) [Test-Path], ParameterBindingValidationException
    + FullyQualifiedErrorId : ParameterArgumentValidationErrorEmptyStringNotAllowed,Microsoft.PowerShell.Commands.TestPathCommand


Executing task: nuget-setup
An error occurred when executing task 'nuget-setup'.
Error: Could not find file 'C:\Delete\GooglePlayServicesComponents-master\externals\m2repository.zip'.

Is that supposed to work? I'm blocked on moving forward with testing/verifying this....
Comment 3 Daniel Cazzulino 2017-04-06 16:08:19 UTC
Hm... the readme is *very* confusing. It says

> You may need to first build the externals target

When it's actually you *must* build the externals targets!
Comment 5 Daniel Cazzulino 2017-04-06 16:13:29 UTC
With latest VS2017 stable and Xamarin installed, I don't see any dialogs poping up. I have .NET Desktop and Xamarin installed via the Visual Studio installer.
Comment 6 thomas 2017-04-06 16:17:32 UTC
I guess it was a VM 2015 Problem so it's entirely possible that Vs 2017 works fine