Bug 52479 - MT3001 Error or Native Class hasn't been loading error
Summary: MT3001 Error or Native Class hasn't been loading error
Status: NEW
Alias: None
Product: Objective Sharpie
Classification: Desktop
Component: General ()
Version: master
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Aaron Bockover [MSFT]
Depends on:
Reported: 2017-02-13 16:28 UTC by ryan.hirschthal
Modified: 2017-02-13 22:36 UTC (History)
0 users

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 52479 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description ryan.hirschthal 2017-02-13 16:28:13 UTC
I have been working making a iOS binding library for the Wahoo fitness framework, and when I try to compile it, I get one of 2 errors

The first error I get is if I try to build for the sim (debug|iPhoneSim), this allows me to build, but the first call to the framework crashes, saying that me calling to get a singleton reference is null. If I comment out those lines, and get to the first line from the framework that doesn't have a singleton reference, I get the error "native class hasn't been loading". From my research, that means that the framework was not supporting the chip architecture. But this is the same framework that is running their example projects, which work just fine. 

If I run it for the phone itself (debug|iPhone), I get the error MT3001. As far as I know, that is a bug and should be reported as such. I have tried disabling the incremental builds, but that does not help with this problem.

I have ran into a little bit of objective sharpie trouble before, and noted it on the forums:

Attached is the framework, the binding library, and the test app. Hopefully they are small enough to fit.
Comment 1 ryan.hirschthal 2017-02-13 22:36:20 UTC
Unable to attach, Here is a url to the zip