Bug 52424 - Editor not showing a keyboard upon focus in iOS
Summary: Editor not showing a keyboard upon focus in iOS
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 2.3.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jimmy [MSFT]
Depends on:
Reported: 2017-02-09 16:48 UTC by Dimitar Dobrev
Modified: 2017-03-02 09:08 UTC (History)
3 users (show)

Tags: ios, keyboard
Is this bug a regression?: ---
Last known good build:

sample project (28.08 KB, application/zip)
2017-03-01 18:20 UTC, Jimmy [MSFT]

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Dimitar Dobrev 2017-02-09 16:48:04 UTC
Only the bottom row with "Done" is visible. I tried with Keyboard="Text" and with nothing i.e. with "Default". I haven't tried if it works with the stable 2.3.3 because I need the pre-release because of Frame.CornerRadius.
Comment 1 adrianknight89 2017-02-12 23:05:43 UTC
Can you attach a minimal repro?
Comment 2 Dimitar Dobrev 2017-02-12 23:32:17 UTC
No, I can't. Did you try it yourself AT ALL?
Comment 3 Dimitar Dobrev 2017-02-14 12:33:08 UTC
Forgot to clarify that this happens on a simulator of iPhone 4s with iOS 9.0. I cannot test on a device so I don't know if it works there.
Comment 4 Jimmy [MSFT] 2017-03-01 18:19:50 UTC
I tested this on a device and the issue did not happen there, but on a simulator I did only see the "Done" button as you mentioned. As it occurs on the simulator, I think this is because by default the on-screen keyboard will not pop up on the simulator since it thinks a hardware keyboard is connected. 

In the simulator menu bar, go to to "Hardware > Keyboard" and uncheck "Connect Hardware Keyboard". Now when you tap the Editor the on-screen keyboard should appear.

I've attached the sample project I tested with. If you are able to repro with the setting above disabled or on a device, feel free to re-open this report. Thanks!
Comment 5 Jimmy [MSFT] 2017-03-01 18:20:12 UTC
Created attachment 20065 [details]
sample project
Comment 6 Dimitar Dobrev 2017-03-02 09:08:33 UTC
Jimmy, the setting worked. Thank you very much for clearing this one up. You may consider it closed. All the best to you.