Bug 51809 - TextCell in ListView does not appear Android API 19
Summary: TextCell in ListView does not appear Android API 19
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.3.3
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2017-01-27 09:21 UTC by MartyG
Modified: 2017-06-23 14:06 UTC (History)
6 users (show)

Tags: android listview
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description MartyG 2017-01-27 09:21:29 UTC

The propriety "Text" of the TextCell does not appear in Android API 19 but other property like the property details of the TextCell work in ListView and TableView

This problem occurs after updating xamarin form to the latest version ( and it worked before (previous version :

Steps to Reproduce: 

1. Create a Cross-Platform Blank Xaml App
2. In Portable solution create a listview with ItemSource and a TextCell inside
3. Insert the property Text of the TextCell 

Actual Results:

The property Text does not appear with an Android API 19 , i have tried on API 22 and it works
Comment 1 MartyG 2017-01-27 09:34:13 UTC
Sample :  https://github.com/mgaucher/TestTextCell
Comment 2 MartyG 2017-01-27 12:27:11 UTC
I have found out that the text does not appear because of the default color property . If i change the TextColor to blue for example it works, but if i change it to default i have the same bug.

sample to use on API 19 : https://github.com/mgaucher/TestTextCell
Comment 3 E.Z. Hart [MSFT] 2017-06-19 17:26:08 UTC

I cloned your project from GitHub and ran it on an API 19 emulator, and both the primary and detail text showed up in the cells of both ListViews. 

Is there something else I need to do in the repo to reproduce the bug?
Comment 4 David Ortinau [MSFT] 2017-06-23 14:06:58 UTC

If this is still occurring for you, please reopen this issue and provide a new project that demonstrates the issue along with additional details about your environment etc. 

Since we're not able to reproduce it, I'm going to close this issue for now.