Bug 51701 - Default Android App on beta channel does not compile
Summary: Default Android App on beta channel does not compile
Alias: None
Product: Android
Classification: Xamarin
Component: Bindings ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Atsushi Eno
Depends on:
Reported: 2017-01-23 11:52 UTC by Jon Sporring
Modified: 2017-01-23 15:05 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Jon Sporring 2017-01-23 11:52:10 UTC
A bug in the stable version (https://bugzilla.xamarin.com/show_bug.cgi?id=51601), caused me to upgrade to beta. This solved one problem an introduced another:

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: Error: java.lang.UnsupportedClassVersionError: com/android/dx/command/Main  :  Unsupported major.minor version 52.0 (test)

I suppose that I have to change some library to be linked with. I'm novice with both xamarin and Android development, so I have so far not been able to understand how to do that. Regardless, it seems less than pedagogical at present for newbies like me.

To reproduce, create a new Android app project and compile.
Comment 1 Jon Sporring 2017-01-23 15:05:35 UTC
Sorry, I solved this myself. Needed to remove 


and install 


Java is a mess on osx.