Bug 51683 - Visual Studio Emulator for Android shows black screen when launching games built with newer versions of Unity
Summary: Visual Studio Emulator for Android shows black screen when launching games bu...
Alias: None
Product: Tools
Classification: Mono
Component: other ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2017-01-21 02:36 UTC by itsucksthemost
Modified: 2017-05-31 16:41 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description itsucksthemost 2017-01-21 02:36:55 UTC
Games built with newer versions of Unity (5.0+) display only a black screen when run on the emulator. The game runs properly and you can even hear the gameplay happening and interact with the UI etc, but the screen is completely black.

This post describes some tests that were made: http://answers.unity3d.com/questions/1243769/unity-54-visual-studio-emulator-for-android-blacks.html

"Hi there, I am trying to use Visual Studio Emulator for Android but when I launch the game, I get a blackscreen and nothing else. I tried this on completely new project with no script whatsoever but still same. I can open one of my old apk that has been builded by older version of Unity(can't recall which one) and it works perfectly but even an empty project gives blackscreen in Unity 5.4. Here are the things I've tried:

Player Settings:

    Use 32-bit Display Buffer: Both on and off

    Graphics API: OpenGLES2(OpenGLES3 or"Auto Graphics API" gives error on launch and does not launch the game at all)

    Multithreaded Rendering: Both on and off

    Device Filter: I know the emulator works on x86 architecture but I tried FAT(ARMv7 and x86) anyway but no luck again.

    Device Profile: I tried on API Level 23 and API Level 19.

Note that I can launch my game without a problem with my LG G3 device.

This seems to be a Unity-sided problem. If you are encountering this problem too please upvote this question so we can reach devs, even notify them if it's not a known issue."

There are other reports of the same issue all over Unity's Q&A section, but with no proper solution.
Comment 1 Alexander Köplinger [MSFT] 2017-05-31 16:41:54 UTC
This seems to be a Unity-specific problem, please open a bug report with them. Thanks.