Bug 5167 - Could not edit XIB-interface after latest update
Summary: Could not edit XIB-interface after latest update
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: unspecified
Hardware: PC Mac OS
: High normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
: 5365 ()
Depends on:
Reported: 2012-05-18 06:35 UTC by Maxim
Modified: 2012-05-28 17:23 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

When double-click on XIB-file (451.32 KB, image/png)
2012-05-18 06:35 UTC, Maxim
When close message box and switch to XCode (463.46 KB, image/png)
2012-05-18 06:36 UTC, Maxim
Generated Xcode project file with a problem (6.44 KB, application/x-zip)
2012-05-18 14:10 UTC, Maxim

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Maxim 2012-05-18 06:35:46 UTC
Created attachment 1914 [details]
When double-click on XIB-file

After latest update of MonoDevelop from 2.8 to 3 and other products stack it becames impossible to edit XIB file when click over it in solution explorer.

MonoDevelop prints callstack after timeout:
MonoDevelop.MacInterop.AppleScriptException: Xcode got an error: AppleEvent timed out.
  at MonoDevelop.MacInterop.AppleScript.Run (Boolean compile, MonoDevelop.MacInterop.AEDesc& scriptData) [0x00037] in /Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/src/addins/MacPlatform/MacInterop/AppleScript.cs:113 
  at MonoDevelop.MacInterop.AppleScript.Run (System.String scriptSource) [0x00010] in /Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/src/addins/MacPlatform/MacInterop/AppleScript.cs:83 
  at MonoDevelop.MacInterop.AppleScript.Run (System.String scriptSourceFormat, System.Object[] args) [0x00000] in /Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/src/addins/MacPlatform/MacInterop/AppleScript.cs:74 
  at MonoDevelop.MacDev.XcodeSyncing.XcodeMonitor.OpenFile (IProgressMonitor monitor, System.String relativeName) [0x00033] in /Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/src/addins/MonoDevelop.MacDev/XcodeSyncing/XcodeMonitor.cs:304
Comment 1 Maxim 2012-05-18 06:36:22 UTC
Created attachment 1915 [details]
When close message box and switch to XCode
Comment 2 Maxim 2012-05-18 06:39:37 UTC
I unsuccessfully tried to:
- Restart both MonoDevelop and XCode;
- Clean project folders bin and obj.
Comment 3 Maxim 2012-05-18 06:44:34 UTC
MonoDevelop 3.0 (3.0.1)
XCode 4.2.1 (4D502)
Comment 4 Maxim 2012-05-18 09:15:40 UTC
Updated to XCode 4.3.2 (4E2002)
Reinstall latest MonoTouch (5.2.11).

Got new error:
Error updating Objective-C type information. Operation is not supported.

System.NotSupportedException: Operation is not supported.
  at ICSharpCode.NRefactory.TypeSystem.CecilLoader+BlobReader.ReadCustomAttributeFieldOrPropType () [0x00146] in /Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/contrib/ICSharpCode.NRefactory/TypeSystem/CecilLoader.cs:1224 
  at ICSharpCode.NRefactory.TypeSystem.CecilLoader+BlobReader.ReadNamedArg (IType attributeType) [0x00040] in /Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/contrib/ICSharpCode.NRefactory/TypeSystem/CecilLoader.cs:1173 
  at ICSharpCode.NRefactory.TypeSystem.CecilLoader+CecilResolvedAttribute.DecodeBlob (System.Collections.Generic.List`1 positionalArguments, System.Collections.Generic.List`1 namedArguments) [0x0008c] in /Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/contrib/ICSharpCode.NRefactory/TypeSystem/CecilLoader.cs:913 
  at ICSharpCode.NRefactory.TypeSystem.CecilLoader+CecilResolvedAttribute.DecodeBlob () [0x0000c] in /Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/contrib/ICSharpCode.NRefactory/TypeSystem/CecilLoader.cs:894 
  at ICSharpCode.NRefactory.TypeSystem.CecilLoader+CecilResolvedAttribute.get_PositionalArguments () [0x00014] in /Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/contrib/ICSharpCode.NRefactory/TypeSystem/CecilLoader.cs:869 
  at MonoDevelop.MacDev.ObjCIntegration.NSObjectInfoService.ConvertType (MonoDevelop.Ide.TypeSystem.ProjectContentWrapper dom, ITypeDefinition type) [0x00064] in /Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/src/addins/MonoDevelop.MacDev/ObjCIntegration/NSObjectInfoService.cs:174 
  at MonoDevelop.MacDev.ObjCIntegration.NSObjectInfoService+<GetRegisteredObjects>c__Iterator2.MoveNext () [0x000d2] in /Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/src/addins/MonoDevelop.MacDev/ObjCIntegration/NSObjectInfoService.cs:152 
  at MonoDevelop.MacDev.ObjCIntegration.NSObjectProjectInfo.Update () [0x0022a] in /Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/src/addins/MonoDevelop.MacDev/ObjCIntegration/NSObjectProjectInfo.cs:102 
  at MonoDevelop.MacDev.ObjCIntegration.NSObjectProjectInfo.Update (Boolean force) [0x0000c] in /Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/src/addins/MonoDevelop.MacDev/ObjCIntegration/NSObjectProjectInfo.cs:73 
  at MonoDevelop.MacDev.XcodeSyncing.XcodeProjectTracker.UpdateTypes (IProgressMonitor monitor) [0x00031] in /Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/src/addins/MonoDevelop.MacDev/XcodeSyncing/XcodeProjectTracker.cs:392
Comment 5 Jeffrey Stedfast 2012-05-18 12:01:52 UTC
The timeout exception is... well, a timeout. It means that Xcode was taking too long to respond.

Are you on a slow machine? What if you start Xcode manually before double-clicking a .xib in MonoDevelop?

The new error you are getting is a type system bug. I'll reassign to Mike Krueger to look at (it might already be fixed).
Comment 6 Maxim 2012-05-18 14:10:01 UTC
Created attachment 1920 [details]
Generated Xcode project file with a problem
Comment 7 Maxim 2012-05-18 14:10:24 UTC
Yep. I recheck it. Timeout message occur cause of first one message box remain to long and stack has no relations to real issue.

I am using latest Mac mini with Core i5 and 8 gig of RAM. I tried such trick. Works with recently created single-view test project, but not with multi-view relatively old one project.

Who knows, maybe there are some unclosed tags in prepared for Xcode file. So this file now attached.
Comment 8 Jeffrey Stedfast 2012-05-21 11:43:15 UTC
Hmmm, somehow my fix to quote strings (to make project names with spaces in them work) in the files must have gotten reverted during a merge conflict.

Re-fixed in git master and 3.0-series branches.
Comment 9 Maxim 2012-05-21 11:51:21 UTC
What should I do to reach your fix and edit XIBs?
Comment 10 Jeffrey Stedfast 2012-05-21 13:43:15 UTC
try http://files.xamarin.com/~jeff/MonoDevelop-3.0.1js3.dmg
Comment 11 Maxim 2012-05-22 07:05:08 UTC
Confirm. It solves the issue.
Awaiting fix in main branch.
Comment 12 Jeffrey Stedfast 2012-05-22 10:07:53 UTC
awesome, thanks for confirming, maxim!
Comment 13 Mikayla Hutchinson [MSFT] 2012-05-28 17:23:49 UTC
*** Bug 5365 has been marked as a duplicate of this bug. ***