Bug 5130 - mdtool printing assertion
Summary: mdtool printing assertion
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 3.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2012-05-16 16:39 UTC by adam.lickel
Modified: 2012-05-16 17:05 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description adam.lickel 2012-05-16 16:39:14 UTC
I run mdtool from the command line regularly.
With the latest MonoDevelop & MonoTouch I am now seeing the following error message every time I run it:

(mdtool:23251): Gtk-CRITICAL **: gtk_main_quit: assertion `main_loops != NULL' failed

The tool exits with an OK return code, but this is unnecessary noise.
Comment 1 Mikayla Hutchinson [MSFT] 2012-05-16 17:05:04 UTC
This was fixed in master a while back, but I've now backported it to the 3.0.x branch since it seems to be causing some confusion.