Bug 5073 - Visual Studio 2010 crashes after install of 4.2.1 Mono For Android (was running older version with no problem)
Summary: Visual Studio 2010 crashes after install of 4.2.1 Mono For Android (was runni...
Status: RESOLVED DUPLICATE of bug 5063
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2012-05-14 16:17 UTC by alsmyth2
Modified: 2016-08-03 15:22 UTC (History)
8 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description alsmyth2 2012-05-14 16:17:20 UTC
I was working with Mono For Android in VS 2010 with no problems

Then at about 4PM EST today (04.14.2012) when I went to create a new Mono project in VS 2010 I got a notice that version 4.2.1 was available.

So I 
1. downloaded
2. closed out of all Visual Studio sessions
3. installed

Then when I went to open VS 2010 and either pick and existing project, or create a new project Visual Studio crashes (Visual Studio encountered a problem and will have to close).

I tried
4. reboot
- no change (still crashes)
5. uninstall and reinstall
- no change (still crashes)

I noticed the install , even if I run the original still is 4.2.1.
So now I am stuck.
Comment 1 alsmyth2 2012-05-15 08:58:10 UTC
I made an obvious (to me) mistake above wrt dates I said "4PM EST today (04.14.2012)" I meant to say 05.14.2012, i.e. May 14, 2012.

BTW the previous version I was running 9without incident) was installed on 04.25.2012 April 25, 2012 - I'm not sure what version that was but perhaps since the installer seems to download the latest version I thought that might help.
Comment 2 DCarlin 2012-05-15 12:53:13 UTC
I am having the same problem. Each time it crashes, I see the following entry in the Application Log...

Application: devenv.exe 
Framework Version: v4.0.30319 
Description: The process was terminated due to an unhandled exception. 
Exception Info: System.NullReferenceException 
   at Xamarin.AndroidDesigner.JavaProcessConnection.OnConnected(System.IAsyncResult)
   at System.Net.LazyAsyncResult.Complete(IntPtr) 
   at System.Net.ContextAwareResult.CompleteCallback(System.Object) 
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
    at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
    at System.Net.ContextAwareResult.Complete(IntPtr) 
   at System.Net.LazyAsyncResult.ProtectedInvokeCallback(System.Object, IntPtr) 
   at System.Net.Sockets.BaseOverlappedAsyncResult.CompletionPortCallback(UInt32, UInt32, System.Threading.NativeOverlapped*)
    at System.Threading._IOCompletionCallback.PerformIOCompletionCallback(UInt32, UInt32, System.Threading.NativeOverlapped*)
Comment 3 Jonathan Pobst 2012-05-19 12:31:26 UTC

*** This bug has been marked as a duplicate of bug 5063 ***