Bug 49865 - Intellisense AXML not working properly
Summary: Intellisense AXML not working properly
Alias: None
Product: Android
Classification: Xamarin
Component: Designer ()
Version: 7.0 (C8)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Stephen Shaw
Depends on:
Reported: 2016-12-13 16:54 UTC by Arturo Rodriguez
Modified: 2017-06-27 21:30 UTC (History)
5 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:

bug (211.66 KB, image/png)
2016-12-13 16:54 UTC, Arturo Rodriguez

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 49865 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Arturo Rodriguez 2016-12-13 16:54:12 UTC
Created attachment 18871 [details]

Microsoft Visual Studio Community 2015
Versión 14.0.25431.01 Update 3
Microsoft .NET Framework
Versión 4.6.01586
Xamarin (872717c)
Xamarin.Android (ce955cc)

When I try to use the Source tab on the axml editor, intellisense works sometimes and sometimes doesn't. For example, in the pic that I attached, intellisense shows some suggestions like layerType or layoutDirection, but it doesn't show layout_marginBottom. As you can see, layout_marginTop and layout_gravity are marked as "not declared" (it does not recognize them). However, in the Designer tab, they appear (see pic on the right) and they work correctly when I run the application. In other projects, those attributes appear correctly in the intellisense suggestions.

I don't know if it's related but, by default, intellisense does not suggest values like "wrap_content" and "match_parent" in the Source tab. However, if I change those values in the Designer tabs (double clicking in the properties window) and then change to Source tab, the intellisense starts to suggest them.
Comment 1 Jeremy Kolb 2017-04-06 18:27:16 UTC
This has never worked for me since 2013.