Bug 4963 - [SVN] Error checking in code after moving files
Summary: [SVN] Error checking in code after moving files
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Version Control ()
Version: Trunk
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Alan McGovern
Depends on:
Reported: 2012-05-09 07:01 UTC by Alan McGovern
Modified: 2012-06-29 20:01 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Alan McGovern 2012-05-09 07:01:19 UTC
I have a folder with classes in it. I have moved some of the classes to a new folder. I am now getting this check-in error and don't know how to solve it. I have tried an "Update" on the folder and tried to Commit the project again but it is no use.

MonoDevelop.VersionControl.Subversion.SubversionException: Commit failed (details follow):
Item '/iPad/trunk/mOrders/Classes.App' is out of date
at MonoDevelop.VersionControl.Subversion.Unix.SvnClient.CheckError (IntPtr error) [0x0007c] in /Users/builder/data/lanes/monodevelop-mac- 
at MonoDevelop.VersionControl.Subversion.Unix.SvnClient.Commit (MonoDevelop.Core.FilePath[] paths, System.String message, IProgressMonitor monitor) [0x000f6] in /Users/builder/data/lanes/monodevelop-mac- 
at MonoDevelop.VersionControl.Subversion.SubversionRepository.Commit (MonoDevelop.VersionControl.ChangeSet changeSet, IProgressMonitor monitor) [0x00047] in /Users/builder/data/lanes/monodevelop-mac- 
at MonoDevelop.VersionControl.CommitCommand+CommitWorker.Run () [0x00028] in /Users/builder/data/lanes/monodevelop-mac-
Comment 1 Alan McGovern 2012-06-29 20:01:50 UTC
This cannot be reproduced so i think it has been fixed since There was at least 1 commit dealing with this sort of bug.