Bug 496 - Long hangs (eg. one or more minutes) during garbage collection
Summary: Long hangs (eg. one or more minutes) during garbage collection
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler ()
Version: 1.0
Hardware: PC Windows
: --- critical
Target Milestone: ---
Assignee: Jonathan Pryor
Depends on:
Reported: 2011-08-28 11:37 UTC by andrew
Modified: 2011-09-13 17:24 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Comment 3 andrew 2011-09-03 11:49:50 UTC

I'm testing on a Samsung Galaxy S running Android 2.2.

I just tried on the standard Android emulator running Android 2.2 and get "Low Memory: No more background processes" messages as the "Process xxx has died" messages appear during the GC. In that case (ie. on the 2.2 emulator), my app gives a WIN DEATH).

Then I tried on an emulator running Android 3.0. I get the hang - in that case for about 2 minutes. The app the continues fine after the pause.

Are you after a .apk file where the .NET project is compiled in Debug mode? I'll try and get that sorted.


Comment 4 andrew 2011-09-03 12:50:47 UTC
Debug build attached - this is a much smaller .apk but I'm guessing that's because it doesn't include the shared runtime?

Let me know if you need anything else.


Comment 10 Rodrigo Kumpera 2011-09-13 14:46:57 UTC
Hi Andrew,

We figured out the bug and it has been fixed on our side, the long pause is gone.

The fix will be part of our next release.
Comment 11 andrew 2011-09-13 17:24:25 UTC
Excellent, can't wait!