Bug 49238 - [VS2017-RC] The file Default-Portrait@2x.png could not be found within the project templates.
Summary: [VS2017-RC] The file Default-Portrait@2x.png could not be found within the pr...
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Templates ()
Version: 4.5.0 (15.2)
Hardware: PC Windows
: Normal major
Target Milestone: 15.2
Assignee: Pierce Boggan [MSFT]
Depends on:
Reported: 2016-12-07 17:45 UTC by Ben Beckley
Modified: 2017-04-28 19:13 UTC (History)
10 users (show)

Is this bug a regression?: ---
Last known good build:

zipped logs for comment 12 (9.67 KB, application/x-zip-compressed)
2017-03-20 21:32 UTC, Ben Beckley

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Ben Beckley 2016-12-07 17:45:34 UTC
When trying to create a new blank Forms Shared project I am met with the following dialog and the Android project is not created.

Using VS 2017 RC2 and XVS

env info: https://gist.github.com/BenBeckley/aad3dd82bc5a3c923135b5238d620a82
Comment 1 vga 2016-12-26 15:29:12 UTC
I cannot repro with VS build d15rel/26014.

Are you sure you are doing Blank app->Forms->Shared? If so, how many projects do you get created? Maybe there is some other dependency that's causing this. I get iOS, Android and shared project.
Comment 2 Joaquin Jares 2016-12-30 10:25:28 UTC
I tried this too and I'm also not getting a repro.
Comment 3 Emanuel 2017-01-05 16:17:29 UTC
Marking this bug as not reproducible since Victor and Joaquin were not able to reproduce it.
Comment 4 Ben Beckley 2017-01-19 21:43:24 UTC
My apologies for not replying to this sooner. I am reopening this bug because I am hitting it again, but with slightly different conditions than the original report.

When creating a new Blank Native Shared project I am getting the dialog, and the Android project is being created successfully unlike the original description. I have attached a recording to clear any uncertainties.

Reproduction Steps:
1) Start VS2017
2) Select File>New Project
3) Create a new Blank Native Shared Cross-Platform app

Actual Result: This dialog pops up, http://screencast.com/t/inwAYLzwka

Expected Result: There should be no dialog

screencast: https://www.screencast.com/t/ZblYwVEMTK
environment info: https://gist.github.com/BenBeckley/63f522b4a3bd5a1aef8ab4fc70ee325a
Comment 5 Jose Gallardo 2017-01-20 13:10:31 UTC
Hi Ben,

I've tried to repro the issue without luck, using exactly the same version from your screencast.

Looking into the templates, I can see that file exists in my setup, and it's located here:

C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Extensions\rx0xrxsm.dcz\T\P\CSharp\Cross-Platform\Native.Shared.Template.zip\Native.Shared.Template.iOS\Resources\Images.xcassets\LaunchImage.launchimage

The extension subfolder (rx0xrxsm.dcz) can change, you might need to look for the one that includes the Xamarin.Forms.Templates.VisualStudio.dll , pdb and pkdef.

The Native.Shared.Template.zip is a zip file, and the rest of the path is the content of that file.

Some questions:

1) Can you please check if you have the file there? 
2) Does the project build after unfolding? (assuming the file exists).
3) What version of the Templates is installed on that system? (it should be 0.5.130).

I can guess some potential causes for this issue in your environment, but we need to confirm:
- It has an older Templates vsix for some reason.
- A timing issue unfolding the template, which makes VS to perform the check before the file has been unfolded (which can be the case if the answer for q1 and q2 is YES).

Comment 6 Ben Beckley 2017-01-20 17:43:34 UTC
1) That file is located in the respective location.
>C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Extensions\4rjgfvz4.tiv\T\P\CSharp\Cross-Platform\Native.Shared.Template.zip\Native.Shared.Template.iOS\Resources\Images.xcassets\LaunchImage.launchimage

2) Both projects build after unfolding.

3) Yes, Xamarin.Forms Templates is v0.5.130
Comment 7 Joaquin Jares 2017-01-30 12:50:06 UTC
The templates completely changed. I'm marking this as resolved for retesting.
Comment 9 Shruti 2017-02-01 10:04:56 UTC
As per comment8, changing the bug status to verified fixed.

Comment 10 Ben Beckley 2017-02-08 20:53:30 UTC
Reopening as I am still seeing this with the Blank Native template.

env info: https://gist.github.com/BenBeckley/1ef342a4415ca3e269da52bea5bd0df9
Comment 11 Jose Gallardo 2017-02-16 17:39:35 UTC
Discussed with Pierce and Joaquin.
@joj, @ben and @pierce can't repro with latest bits, hence closing the issue.
Comment 12 Ben Beckley 2017-03-20 21:31:46 UTC
Reopening as I am encountering this with a Blank->Native->Shared app using VS2017 26317.55, XVS (8e30194d3), and Xamarin.Forms.Templates 0.5.285

env info: https://gist.github.com/BenBeckley/23016bbdfbee9ff5844eec785dfc56b9
Comment 13 Ben Beckley 2017-03-20 21:32:56 UTC
Created attachment 20475 [details]
zipped logs for comment 12
Comment 14 Ben Beckley 2017-03-20 21:34:22 UTC
I am also increasing the severity as this is now regarded as a build error.
Comment 15 Ben Beckley 2017-03-27 22:59:11 UTC
Realized that the milestone was still C9 when I opened this. Changing to 15.1

Also encountering this with a Master Detail Native Shared app.

>File not found: /Users/Ben/Library/Caches/Xamarin/mtbs/builds/MDNS_App.iOS/13171a89a903bee13ab1365329b0abaa/Assets.xcassets/AppIcon.appiconset/Icon-Small-40.png	MDNS_App.iOS	C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets	1158