Bug 4873 - Zip App Bundle... produces invalid zip
Summary: Zip App Bundle... produces invalid zip
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Hardware: Macintosh Mac OS
: High normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
Depends on:
Reported: 2012-05-03 22:53 UTC by me
Modified: 2013-03-08 19:37 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description me 2012-05-03 22:53:48 UTC
I followed the instructions on the Xamarin site on publishing the app to the store, and after using the Zip App Bundle... workflow in MonoDevelop, the apple application uploader would not accept my .zip file. It would fail on the first step complaining that the bundle could not be validated due to bad cert or distribution profile. After much gnashing of teeth, I followed the instructions to manually compress the file to a zip, and then it worked fine.
Comment 1 Jeffrey Stedfast 2012-05-07 15:30:11 UTC
What documentation did you follow that worked? This might help me narrow down the problem
Comment 2 me 2012-05-07 16:32:55 UTC

This article shows how to zip using MonoDevelop or doing it manually. I did the first way through MD titled 'Using MonoDevelop to Zip the Application Bundle', and after it did not work, I followed the section immediately below it titled 'Manually Zipping the Bundle'
Comment 3 Jeffrey Stedfast 2012-05-09 15:20:47 UTC
Can you attach the 2 zips to this bug report (check the checkbox to mark them as private)?

The zips that MonoDevelop create seem to be identical to what I get when I right-click and select Compress on my machine.
Comment 4 Jeffrey Stedfast 2013-03-08 19:37:29 UTC
Rereading the first comment, it looks like the problem was likely due to not signing the app (probably zipped a Simulator build?)