Bug 48525 - "Couldn't connect to xxx. Please try again - SSHD Error 255
Summary: "Couldn't connect to xxx. Please try again - SSHD Error 255
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: XMA ()
Version: 4.3.0 (C9)
Hardware: PC Windows
: Normal normal
Target Milestone: Future Cycle
Assignee: Bugzilla
Depends on:
Reported: 2016-12-01 13:40 UTC by James Hancock
Modified: 2017-06-28 20:37 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description James Hancock 2016-12-01 13:40:24 UTC
I'm using Visual Studio 2017 RC and this was working perfectly yesterday but no longer works and just miraculously stopped working. I've followed all of the instructions in troubleshooting and none of the 10 steps have issues. (They all work just fine)

When I connect the mac_agent to visual studio it gets the thumbprint etc. just fine. It won't login and comes up with "Couldn't connect to <machine name>. Please try again.

The Xamarin->Zip logs has two files in it and the ios one just has the fingerprint nothing else. The output window in Visual studio for xamarin and xamarin diagnostics shows nothing other than successful android stuff.

The logs for sshd on the mac show the following:

com.apple.xpc.launchd[1] (com.openssh.sshd.96B071C6-7C08-4CF9-B6DC-148AC7365843[9219]): Service exited with abnormal code: 255

I've tried this with Visual Studio for Mac, Xamarin Studio latest stable, beta and alpha now trying to find a way to make this work because we're dead in the water at the moment. I also tried a full format of the mac and reinstall of Sierra and the latest xcode and then went through Xamarin Studio stable/beta/alpha and also did it again and use Visual Studio 2017. Same result indicating to me that it's something on the PC that's causing the issue although it's two separate machines.

The only insight I have possibly is that it immediately stoppped working after I uninstalled the iOS previewer and installed the latest version on one of the machines. The other one just spontaneously stopped working.

I also followed instructions online and created the sshd_config and set PasswordAuthentication Yes in the /private/etc folder just in case that was the issue (the file didn't exist) but that didn't resolve the issue either.

I'm out of ideas. I'm hoping you can help!
Comment 1 mag@xamarin.com 2016-12-01 14:58:36 UTC
Hi James,

This is a very strange behaviour, specially if you mentioned that you re installed the Mac from scratch. Anyways, I will give you some steps to follow, that can help us to diagnose better the issue, if it doesn't solve it. Please find below:

First of all and as a recommendation to have better verbosity on the logs, please start Visual Studio with the /log argument (devenv.exe /log). Doing this, the Ide.log will have more verbosity and details.

1 - Try connecting from Windows to the Mac with Putty, to the same IP that VS is connecting to (or directly to the IP of your Mac). Then verify if the connection could be established or not. This step will tell us if the problem is general or just with our communication framework

2 - If the connections was established on point 1, try connecting to the Mac with VS by manually adding the IP in the "Add New Mac" section of the Server Selector Dialog. Doing this you can ensure that you are connecting in the same way that you did with Putty. This can discard some strange behaviour with the Bonjour discovery service

3 - Revert the ssdh_config change that you did with PasswordAuthentication Yes. You dont' need to set this, and it's better to let in in the default value. Also, you shuld have many other settings in there, most of them commented

4 - Try resetting the sshd on Mac. You can do this easily by going to System Preferences > Sharing, and unchecking and then checking again the "Remote Loging" option

5 - If none of the options helped you, try connecting with VS 2015 and compare. This can discard any particular issue with VS 2017

Finally and if you didn't get rid of this issue, please attach the Ide.log corresponding to the VS session that you used, ensuring that VS was started with /log.

Comment 2 James Hancock 2016-12-01 16:10:45 UTC
So in the mean time I uninstalled the previous version of the Simulator and installed the one that was released today. (1.0.13 I believe) and magically it started connecting at least.
(#1 worked fine, #2 didn't work, but now all ways work, #3 reverted and didn't seem to make a difference anyhow, #4 I did after resetting the change I made and made no difference, #5 I can't do that because VS.net 2017 and 2015 Xamarin can't work side by side...)

Once I updated the simulator it hung on connecting... then I changed to a different image and it worked once. Now it works once I start up of visual studio as long as I change the image each time.

So it looks like this is something in the simulator that is causing problems.
Comment 3 James Hancock 2016-12-02 13:24:48 UTC
On the second machine that I have access to today, it fails as before even with the updated similuator with the exact same mac AND all of the steps that were outlined above have been done and work fine (other than Vs.net 2015 obviously).

So I have one working and one dead installation.
Comment 4 mag@xamarin.com 2017-05-29 18:46:33 UTC
Is this issue still reproducible with latest XVS and Remote Simulator versions? If there are still issues, please attach both VS and Mac logs as requested in Comment 1 in order to analyze the particular case
Comment 5 mag@xamarin.com 2017-06-28 20:37:45 UTC
Since this is a strange behavior that we couldn't reproduce on our end and we didn't get the logs to analyze the particular behavior, I will consider the bug as fixed by having the latest Xamarin VS and Remote Simulator versions installed, given that It looks like related to the remote simulator version somehow.

If any related issue is still present during or after connection to the Mac, please feel free to re open the bug and provide further logs to analyze in depth.