Bug 48464 - Visual Studio 2015 hangs when opening solution
Summary: Visual Studio 2015 hangs when opening solution
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 4.2.0 (C8)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Alonso
Depends on:
Reported: 2016-11-30 21:15 UTC by James
Modified: 2017-01-16 19:16 UTC (History)
7 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description James 2016-11-30 21:15:56 UTC
After updating Xamarin to in Visual Studio 2015, I cannot open my mobile app solution. Visual studio launches and hangs on "Preparing Solution..." indefinitely. It worked fine before the update.

I have tried to delete the .vs and .suo folder/files.

I'm using Windows 10 Pro 64-bit Build 14393
Comment 1 Ben Beckley 2016-12-01 18:45:40 UTC
Hi James,

Could you please start devenv.exe with the /log argument, and retrieve the ActivityLog.xml file from 

Then upload that file so we can see what is happening with VS? Also, it wouldn't hurt to upload the Xamarin Logs as well, which are accessible from Help>Xamarin>Zip Logs.

Thank you, and I am sorry that the update is causing you troubles.
Comment 2 Adrian Alonso 2016-12-22 17:49:11 UTC
Hi James, have you been able to fix this issue? Thanks, Adrian
Comment 3 James 2016-12-22 17:58:07 UTC
It is no longer an issue for me, and I don't recall exactly what I did to resolve the problem as I was trying lots of fixes I apologize. Thanks for the help. I believe in the end I had to re-install everything.

Comment 4 Juan Marcelo Tondato 2017-01-16 19:16:06 UTC
As we've introduced several improvements around VSX load extension, I'll mark the bug as resolved.
Please feel free to reopen it if you can still reproduce the issue with current bits.