Bug 47718 - Error in Path to Proguard jar
Summary: Error in Path to Proguard jar
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 7.0 (C8)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
Depends on:
Reported: 2016-11-23 14:37 UTC by Preetham
Modified: 2018-03-28 15:38 UTC (History)
7 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Preetham 2016-11-23 14:37:41 UTC
When you attempt to build a solution using Visual Studio 2017 RC, the proguard path has an extra character which results in the jar not being found.

Current result:

6>CREATEMULTIDEXMAINDEXCLASSLIST : error : Unable to access jarfile C:\Android\android-sdk\tools\proguard"\lib\proguard.jar -injars

Expected Result:

The path above should not have the extra '"' in the proguard directory name.

Steps to reproduce:

1. Create a new Blank Android Project in Visual Studio 2017 RC
2. Check the Multidex box under the project properties
3. Rebuild

System Information:

Visual Studio Information:

Microsoft Visual Studio Enterprise 2017 RC
Version 15.0.25920.0 D15REL
Microsoft .NET Framework
Version 4.6.01038

Installed Version: Enterprise

Architecture Diagrams and Analysis Tools   00369-50000-00000-AA769
Microsoft Architecture Diagrams and Analysis Tools

Visual Basic 2017 RC   00369-50000-00000-AA769
Microsoft Visual Basic 2017 RC

Visual C# 2017 RC   00369-50000-00000-AA769
Microsoft Visual C# 2017 RC

Visual C++ 2017 RC   00369-50000-00000-AA769
Microsoft Visual C++ 2017 RC

Visual F# 4.1   00369-50000-00000-AA769
Microsoft Visual F# 4.1

Command Bus, Event Stream and Async Manager   Merq
Provides ICommandBus, IEventStream and IAsyncManager MEF services for loosely coupled Visual Studio extension components communication and integration.

Common Azure Tools   1.8
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

GitHub.VisualStudio   1.0
A Visual Studio Extension that brings the GitHub Flow into Visual Studio.

JavaScript Language Service   2.0
JavaScript Language Service

Microsoft Visual Studio VC Package   1.0
Microsoft Visual Studio VC Package

Mono Debugging for Visual Studio   Mono.Debugging.VisualStudio
Support for debugging Mono processes with Visual Studio.

NuGet Package Manager   4.0.0
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

Xamarin (290c061)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android (23ad1d8)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS (7c50b27)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 1 Si Burgess 2016-11-23 16:24:14 UTC
I'm experiencing the same issue, same version of VS 2017 RC as Preetham's bug report.
Comment 2 Si Burgess 2016-11-25 15:03:09 UTC
I've tried deselecting the "Enable Proguard" option in the Project Properties and rebuilding the Solution but the build process still tries to find the proguard.jar on the bad path and fails.

I'm now left in the position where I'm unable to build ANY Android based projects as my VS 2015 installation is now broken as noted in the Cycle 9 release notes:

"[Xamarin.VS] – At this time, as a result of VS 2017 moving away from .msi packaging toward utilization of the Visual Studio Installer system, Xamarin for Visual Studio 2017 can not be installed side by side with Xamarin for Visual Studio 2015/2013/2012. Please note that installing Xamarin to Visual Studio 2017 will render any previous installation of Xamarin in an earlier version of Visual Studio inoperable."
Comment 3 Denis 2016-11-28 23:19:55 UTC
Have the same issue. Is any workaround possible here?
I have this text: >>>>>>>Unable to access jarfile C:\Android\android-sdk\tools\proguard"\lib\proguard.jar -injars 'C:\Program<<<<<<<
I suggest two issues may occur here. Char >>>>"<<<< in path concatenation between ProguardToolPath (from Xamarin.Android.Common.targets) and 'proguard.jar' location or 'C:\Program??????? cannot read using path with whitespaces.
But I really think first issue more suitable.
Comment 4 Si Burgess 2016-11-30 12:39:20 UTC
I gave up, uninstalled VS 2017 RC, all Xamarin references then reinstalled Xamarin into VS 2015. Will hope this will be fixed when the final VS 2017 is released.
Comment 5 John Miller [MSFT] 2017-06-30 19:33:42 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Android and Visual Studio 2017 (15.2). If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction project and version information.
Comment 6 Xonshiz 2017-08-30 05:29:45 UTC

I'm on VS (15.3.3) and I'm having the same issue. Seems like there's something wrong with VS or Xamarin again.

I've even tried reinstalling VS and Xamarin all over again on my Laptop. The same project builds on my PC (which has 15.2).

I had VS 15.2 on my laptop a few hours ago and I had the same problem. So, I thought about updating it. I've rebooted my Laptop and it's annoying.
I'm running VS  as an "Admin" and still having the same problem.

However, I get this error path :

Severity  Code  Description  Project  File  Line  Suppression State
Error    Unable to access jarfile E:\MyProject\packages\name.atsushieno.proguard.facebook.\build\..lib\proguard.jar MyProject  E:\MyProject\MyProject\CREATEMULTIDEXMAINDEXCLASSLIST
Comment 7 Christophe C 2018-03-28 14:11:47 UTC
I got this error just now.

=== Visual Studio Enterprise 2017 for Mac ===

Version 7.4.1 (build 48)
Installation UUID: e4adac5e-3f12-4f54-a8ad-05b117b60cfb
	Mono (2017-10/6bf3922f3fd) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 508010000

=== NuGet ===

Version :

=== .NET Core ===

Runtime : /usr/local/share/dotnet/dotnet
Versions du runtime :
SDK : /usr/local/share/dotnet/sdk/2.1.4/Sdks
Versions du SDK :
SDK MSBuild : /Library/Frameworks/Mono.framework/Versions/5.8.1/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version : 1.6.1
Emplacement : /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 9.2 (13772)
Build 9C40b

=== Xamarin.Mac ===

Xamarin.Mac not installed. Can't find /Library/Frameworks/Xamarin.Mac.framework/Versions/Current/Version.

=== Xamarin.iOS ===

Version: (Visual Studio Enterprise)
Hash: 3979d081
Branch: d15-6
Build date: 2018-03-09 16:22:34-0500

=== Xamarin.Android ===

Version : (Visual Studio Enterprise)
Android SDK: /Users/Christophe/Library/Android/sdk
	Versions Android prises en charge :
		4.1(Niveau d’API 16)
		4.3(Niveau d’API 18)
		4.4(Niveau d’API 19)
		5.1(Niveau d’API 22)
		6.0(Niveau d’API 23)
		7.1(Niveau d’API 25)
		8.0(Niveau d’API 26)
		8.1(Niveau d’API 27)

Version des outils du SDK : 26.1.1
Version des outils de plateforme du SDK : 27.0.1
Version des outils de génération du SDK : 27.0.3

Java SDK: /usr
java version "1.8.0_131"
Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

Code EPL d'Android Designer disponible ici :

=== Xamarin Inspector ===

Version: 1.4.0
Hash: b3f92f9
Branch: master
Build date: Fri, 19 Jan 2018 22:00:34 GMT
Client compatibility: 1

=== Build Information ===

Release ID: 704010048
Git revision: 6a86203dd590c6cfdf814c8832d24d2ad1e2606f
Build date: 2018-03-20 11:16:55-04
Xamarin addins: 8d83cea9e4ae03cb0c14ba3fbaafdbb0cbd170e7
Build lane: monodevelop-lion-d15-6

=== Operating System ===

Mac OS X 10.13.3
Darwin 17.4.0 Darwin Kernel Version 17.4.0
    Sun Dec 17 09:19:54 PST 2017
    root:xnu-4570.41.2~1/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

Redth's Addins 1.0.9
Internet of Things (IoT) development (Preview) 7.1
Comment 8 dean.ellis 2018-03-28 15:38:40 UTC
Are you able to provide diagnostic build output?